CLK Folding Mirrors

DPP

Member
Joined
Aug 11, 2009
Messages
20
Reaction score
0
Location
Hampshire
Your Mercedes
S Class, 1991, 300se
I have seen several posts but can't determine is the motor of the switch needs replacing.

My electric folding passenger mirror seems to work once in a while, it sometimes only works when I am driving. When I stop and turn the car off I fold in the mirrors and after that they will not fold out again, sometimes one will work while I press the button several times while driving. At the moment the drivers is out but the passenger side is closed. I have checked the fuse in the bonnet and it seems fine, is there another?
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
What can happen is that the joints the the mirrors pivot on become too stiff,,spraying some PTFE into the joint and turning them by hand a few times will free them up. if this does not work, then its possible that a wire from the motor is broken
 

bigasotonuk

Senior Member
Joined
Nov 14, 2006
Messages
5,322
Reaction score
49
Age
53
Location
Southampton UK
Your Mercedes
C43/55 AMG 1999 / C230K 1997
There is only one fuse for the folding function in the main fuse box under the bonnet, though as Malc says the folding hinge does have a tendency to seize, electrically the folding system is very simple and only consists of the 2 mirror motors and a switch, if you have had both mirrors operating allbeit not at the same time i would inclined to think it was a faulty switch.
 
OP
D

DPP

Member
Joined
Aug 11, 2009
Messages
20
Reaction score
0
Location
Hampshire
Your Mercedes
S Class, 1991, 300se
  • Thread Starter
  • Thread starter
  • #4
Thanks

What can happen is that the joints the the mirrors pivot on become too stiff,,spraying some PTFE into the joint and turning them by hand a few times will free them up. if this does not work, then its possible that a wire from the motor is broken

Excellent, Both are working fine after spraying some oil. Job done. Cheers for the quick response.
 
Top Bottom