Cls 08 third brake light problem

Alenacls

New Member
Joined
Apr 10, 2020
Messages
4
Reaction score
1
Your Mercedes
CLS 08 320CDI
Hi
I have 2008 CLS 320Cdi and have message on dashboard for last few weeks third brake light not working.
I've spent half of day to get lamp out but lamp it self is fine and work.
Wire seems to be fine I've traced it near to fuse box can't see any damage.
I have checked fuses all good
Can anyone had same problem?
Help pleeeease!
 

Dean Fletcher

Senior Member
Joined
Mar 24, 2018
Messages
4,296
Reaction score
3,309
Location
Penrith, Cumbria
Your Mercedes
Mercedes E400
Hello and welcome. I had the same issue on my e class I imagine the wiring will be similar, I originally thought it was the light itself I was wrong. I had to trace to wiring all the way back properly about 5ft into the car. The wiring harness on mine goes through the right side boot hinge then down the right side of the car. I had to remove some of the trim to get to it and there it was roughly 4 or 5ft down there was one of the wires in the harness that had split. Quick soldering session, iso tape and a cable wiring strap job done. The thing that got me was where the wire had broke there was absolutely nothing there that could have caused it as it was all wrapped up. Very strange.
 

star

Forum Supporter
Authorised Forum Supporter
Joined
Oct 6, 2004
Messages
6,230
Reaction score
1,894
Location
Reading
Your Mercedes
Smart + others :)
Check wiring around boot hinge point, often snaps.
 
OP
A

Alenacls

New Member
Joined
Apr 10, 2020
Messages
4
Reaction score
1
Your Mercedes
CLS 08 320CDI
  • Thread Starter
  • Thread starter
  • #4
Thanks
I'll have to check wiring again.
 

PB53CLS

Senior Member
Joined
Jun 24, 2016
Messages
78
Reaction score
22
Location
Paisley
Your Mercedes
2010 CLS350 CDI Grand Edition
Happened to me on my 2010 CLS.Electrician told me on the phone what was wrong,he'd repaired so many!Apparently the wiring loom could have been an an inch or so longer and prevented cable stretching and eventually breaking.Took longer to remove and replace boot trim than it did to solder wiring!Been fine ever since.
 
OP
A

Alenacls

New Member
Joined
Apr 10, 2020
Messages
4
Reaction score
1
Your Mercedes
CLS 08 320CDI
  • Thread Starter
  • Thread starter
  • #6
It was earth/brown cable I couldn't see it it was wrapped up with fabric tape.
If you trace light cable it is behind back seat and it's in the loom at the background lying on the wing so it didn't make sense to me to look for it there but earth must be connected to that one.
Solved,crimped and taped.
I think problem is padding on side panel and cable get caught on it.
Thanks everyone.
 

Attachments

  • 20200412_112038.jpg
    20200412_112038.jpg
    168.2 KB · Views: 16
  • 20200412_110822.jpg
    20200412_110822.jpg
    174.9 KB · Views: 16
  • 20200412_112907.jpg
    20200412_112907.jpg
    178.4 KB · Views: 16

star

Forum Supporter
Authorised Forum Supporter
Joined
Oct 6, 2004
Messages
6,230
Reaction score
1,894
Location
Reading
Your Mercedes
Smart + others :)
You need to remove the cable tie, it allows the wires to flex over a greater distance and will last longer.
 

Edgars

New Member
Joined
Apr 15, 2020
Messages
2
Reaction score
0
Your Mercedes
CLS W219 350 CGI
Hello everyone,

So I've got this Mercedes-Benz CLS 2006 CGI W219.
My 3rd brake light doesn't work, doesn't flicker or give any other sign. It's been like this for a while.
So I got enough of it and wanted to fix it.

On my car I had to take out rear seats, fully seat cushions and also backrests in one piece. To remove rear panel with the 3rd light in it I had to remove headrests. After that I took out a piece on each side to slide out the deck. So I got it all out.
Looked at the brake light it looks great, all the wires are normal and everything seems to be working.
So I couldn't figure it out ony own.
Took it off and Went to my friend to check the light with some electricity directly on a light and the light itself works as new. All the wires are normal. The clip where the light is attached isn't broken.
I've attached some pictures to show how the wiring is located. So basically when I attach the light on the connector it goes somewhere where I possibly can't get thru.
It's not even trunk. It goes on side, by the rear window and ends don't know where.

Maybe someone here had to experience the same problem and knows the solution?
Because it's getting even more frustrating right now.
 

Attachments

  • 2A1522AB-F00B-4D3E-8C49-E828EEAFD227.jpeg
    2A1522AB-F00B-4D3E-8C49-E828EEAFD227.jpeg
    386.3 KB · Views: 12
  • 7D2A55F8-C531-4949-9995-90054B2B8C03.jpeg
    7D2A55F8-C531-4949-9995-90054B2B8C03.jpeg
    299.1 KB · Views: 12
  • 8583319D-3E99-4A11-A545-2315868915C4.jpeg
    8583319D-3E99-4A11-A545-2315868915C4.jpeg
    438.2 KB · Views: 12
  • ABE90767-0ED8-4125-B44D-EC4BDA303B94.jpeg
    ABE90767-0ED8-4125-B44D-EC4BDA303B94.jpeg
    218.7 KB · Views: 13
OP
A

Alenacls

New Member
Joined
Apr 10, 2020
Messages
4
Reaction score
1
Your Mercedes
CLS 08 320CDI
  • Thread Starter
  • Thread starter
  • #9
Hi
I have had same problem and it was broken brown cable located next to left boot hinge(check pictures above) couldn't see it first because wiring loom is wrapped in black tape.
I've done same what you did dismantled whole rear of the car.
Check loom next to hinge,unwrap tape and it could be 5minutes job.
 

mioba

Senior Member
Joined
Feb 19, 2006
Messages
7,965
Reaction score
4,716
Location
Nottingham and Köln
Your Mercedes
W124/E200, W220/S320CDI, W205/C200, W251/R350CDI 4Matic
Get a multimeter out and start tracing backwards
 

Edgars

New Member
Joined
Apr 15, 2020
Messages
2
Reaction score
0
Your Mercedes
CLS W219 350 CGI
Hi
I have had same problem and it was broken brown cable located next to left boot hinge(check pictures above) couldn't see it first because wiring loom is wrapped in black tape.
I've done same what you did dismantled whole rear of the car.
Check loom next to hinge,unwrap tape and it could be 5minutes job.


Yea, traced my wire back to the trunk, but it doesn't go up to a hinge, it goes to the side where the Nav CD box is located.
Will try looking.
 

star

Forum Supporter
Authorised Forum Supporter
Joined
Oct 6, 2004
Messages
6,230
Reaction score
1,894
Location
Reading
Your Mercedes
Smart + others :)
Your third brake light is in a different position to the one above in the wiring repair. I would be checking the rear Sam via star diagnostics.
 

You lost your key ? Or maybe you need a spare! Your vehicle imobilliser does not respond anymore? WE CAN FIX THEM ALL !! Mobile ! Save Time and Increase Profits With us !
Top Bottom