Cold engine problem

aydnk

Member
Joined
Jan 29, 2021
Messages
11
Reaction score
0
Your Mercedes
W210/1998/M112.911 ( 2.4 V6 )
Hello i own W210 2.4 V6. When engine is cold. i give a gas little bit. engine dies and weird (pak-pak) noise coming from engine.But it works perfect when engine is hot. can you tell me guys whats the problem? ( sorry for my bad english i am not living in US)
Here is video about my problem
 
OP
A

aydnk

Member
Joined
Jan 29, 2021
Messages
11
Reaction score
0
Your Mercedes
W210/1998/M112.911 ( 2.4 V6 )
  • Thread Starter
  • Thread starter
  • #2
Replaced MAF two times, cleaned throttle body , injectors.
Computer shows nothing no codes
 

00slk

Senior Member
Joined
Dec 1, 2012
Messages
9,753
Reaction score
9,512
Location
Cambridgeshire UK
Your Mercedes
2002 SL55 AMG, 2005 E320 CDi, 2014 SLK250 CDi, 2003 SLK200
Sounds like sucking air in from somewhere?
 

Gazwould

Senior Member
Joined
Oct 28, 2018
Messages
2,596
Reaction score
1,773
Your Mercedes
C250 CDI
A leak defo .
 
OP
A

aydnk

Member
Joined
Jan 29, 2021
Messages
11
Reaction score
0
Your Mercedes
W210/1998/M112.911 ( 2.4 V6 )
  • Thread Starter
  • Thread starter
  • #5
When engine warms up. it works like a horse zero problem
 
OP
A

aydnk

Member
Joined
Jan 29, 2021
Messages
11
Reaction score
0
Your Mercedes
W210/1998/M112.911 ( 2.4 V6 )
  • Thread Starter
  • Thread starter
  • #6
Maybe EGR problem what you think guys?
 

Avantgarde Automotive, Mercedes-Benz and SLR McLaren specialists. Service, repairs, diagnosis and motorsport preparation.
Unit 14 Hither Green Trading Estate, Clevedon, Somerset, BS21 6XU Tel: 01275 217270 Email:steve@avantgarde-automotive.co.uk
www.avantgarde-automotive.co.uk
Top Bottom