Comand shutting down

nfptuk

New Member
Joined
Nov 5, 2016
Messages
7
Reaction score
0
Location
Bournemouth
Your Mercedes
E/2005/3.2
Hi everyone,

I’m a proud owner of a Mercedes-Benz E320 CDI Avantgarde (W211) from 2005. One year ago I was told that I needed a new rear SAM unit due to the rear windscreen demister not working. The one that came with the car has the following details:

Part Number: A2115455101
Q:02
HW:1104
SW:2604

I got a second hand one (fully working and tested previously) with the last replacement showing on EPC:

Part Number: A2115455301

I requested to be replaced but the initial problem didn’t go away and got a new one, the Comand shows the logo and after a few seconds shuts down and the CD changer doesn’t work, I followed the test on this video:


During the loop teste none accused being the cause of the problem, tested:
- Navigation Unit
- Audio Gateway
- Voice module
- CD Changer

Any idea what could have caused or how to solve the problem? The issue is exactly the on in the video.
 
OP
N

nfptuk

New Member
Joined
Nov 5, 2016
Messages
7
Reaction score
0
Location
Bournemouth
Your Mercedes
E/2005/3.2
  • Thread Starter
  • Thread starter
  • #3
STAR couldn't detect any problem besides not being able to communicate with the Comand Unit, the amplifier was tested with a fiber cable bypass.
 

Submariner1

Senior Member
Joined
Sep 3, 2016
Messages
4,456
Reaction score
632
Location
Windsor Berkshire
Your Mercedes
CL500 2009 5.5
STAR couldn't detect any problem besides not being able to communicate with the Comand Unit, the amplifier was tested with a fiber cable bypass.

No stored faults on STAR?

My understanding is you cant bypass the Amp ( well not on my car ).
The lollipop is to bypass all the other parts, to exclude them from the possible faulty list.
But if you cut out the “heart” it cant work. On mine you would also by definition be bypassing the AGW so it would never run.
My understanding is this lollipop can be used on other items such as the SAT Nav unit, or CTel link .. just to complete the MOST ring. Idea being, if the Amp (and on mine the integral AGW) is suspect, the lollipop just proves that the other components are not stopping the MOST ring completing the circle.

What exactly happened when you bypased the Amp. ? Bet it didnt run and give you sound?

I also beleive you cant bypass the main Comand unit for similar reasons ( but I am not sure on this element) .

I am no expert, just passing on what I was told.

.

I can imagine your frustration, likewise I was told its much easier to diagnose, once my intermitant fault plays up, and they can get a Star readout.

Hence, In light of yours having no faults from STAR, I think you need help from Comand Online, they know pretty much everything about these systems
 
OP
N

nfptuk

New Member
Joined
Nov 5, 2016
Messages
7
Reaction score
0
Location
Bournemouth
Your Mercedes
E/2005/3.2
  • Thread Starter
  • Thread starter
  • #5
No stored faults on STAR?

My understanding is you cant bypass the Amp ( well not on my car ).
The lollipop is to bypass all the other parts, to exclude them from the possible faulty list.
But if you cut out the “heart” it cant work. On mine you would also by definition be bypassing the AGW so it would never run.
My understanding is this lollipop can be used on other items such as the SAT Nav unit, or CTel link .. just to complete the MOST ring. Idea being, if the Amp (and on mine the integral AGW) is suspect, the lollipop just proves that the other components are not stopping the MOST ring completing the circle.

What exactly happened when you bypased the Amp. ? Bet it didnt run and give you sound?

I also beleive you cant bypass the main Comand unit for similar reasons ( but I am not sure on this element) .

I am no expert, just passing on what I was told.

.

I can imagine your frustration, likewise I was told its much easier to diagnose, once my intermitant fault plays up, and they can get a Star readout.

Hence, In light of yours having no faults from STAR, I think you need help from Comand Online, they know pretty much everything about these systems

I just ended testing and you're are right, the Audio Gateway cannot be tested by bypass only by replacing with another unit. The symptoms never change while testing the Navigation Unit Module, the Voice Unit Module and the CD Changer Module. AMG logo shows up, 4 seconds after it shutdowns, and the CD changer doesn't work. When someone connect the Start it was not able to communicate with the Head Unit (Console Unit), nothing else was checked I think.
 

Botus

Senior Member
Joined
Jul 29, 2014
Messages
4,473
Reaction score
1,239
Location
UK
Your Mercedes
S500/2010/500
get on the M3 and go see commandonline at lightwater
 

Headhurts

Senior Member
Joined
Jul 24, 2014
Messages
932
Reaction score
244
Location
Norwich, Norfolk
Your Mercedes
E350 Night Edition Estate/2016/Diesel
As Botus said contact Comand in Lightwater, they are forum sponsors and there is not much they don’t know about these systems.

They are very helpful so a phone call first may be an idea.

Best of luck sorting it.

Robin


Sent from my iPad using Tapatalk
 

Botus

Senior Member
Joined
Jul 29, 2014
Messages
4,473
Reaction score
1,239
Location
UK
Your Mercedes
S500/2010/500
....I don't really understand the fault you have.

You had a faulty rear SAM you changed it and till have the fault
or you changed it and introduced another "new" fault?

I don't know but wouldn't be too surprised if the SAM needs programming to suit the toys your specific car has... we had a similar post and lots chipped in say it should work. Yes certainly should "just" work if the car was exact same build as yours. Which in many cases with Merc being so basic and no one adding the right toys when bought new, would be the case.

But I think a CD changer and Nav were optional if the SAM doesn't expect to see these it won't work. Most other manu you programme the SAM / ZFE / GEM (Merc / BMW / Ford) to suit the toys the car has. Its just a posh fuse box with a small brain
 
OP
N

nfptuk

New Member
Joined
Nov 5, 2016
Messages
7
Reaction score
0
Location
Bournemouth
Your Mercedes
E/2005/3.2
  • Thread Starter
  • Thread starter
  • #10
The initial fault was and is the rear windscreen desmister, still not working, but after I asked a garage to change the rear SAM the GPS/Radio/CD Changer stopped working, I reversed everything and put the old rear SAM back but nothing changed.
 

Botus

Senior Member
Joined
Jul 29, 2014
Messages
4,473
Reaction score
1,239
Location
UK
Your Mercedes
S500/2010/500
The initial fault was and is the rear windscreen desmister, still not working, but after I asked a garage to change the rear SAM the GPS/Radio/CD Changer stopped working, I reversed everything and put the old rear SAM back but nothing changed.


do you know this lovely garage well ?

did they not reconnect something
break something
swap your good command unit for a broken one
 
OP
N

nfptuk

New Member
Joined
Nov 5, 2016
Messages
7
Reaction score
0
Location
Bournemouth
Your Mercedes
E/2005/3.2
  • Thread Starter
  • Thread starter
  • #12
do you know this lovely garage well ?

did they not reconnect something
break something
swap your good command unit for a broken one
I trust them although I asked to disconnect the battery 1h before swapping the Rear SAM and they didn't do it. About the Rear SAM Units, I had pictures of them previously to put the car in the garage. When I swap it back I made sure everything was connected, saw some youtube videos and diagrams about the wires. Since then I tested in the last week everything again with my own fiber optic loop cables, disconnecting everything and connecting again.
 

Botus

Senior Member
Joined
Jul 29, 2014
Messages
4,473
Reaction score
1,239
Location
UK
Your Mercedes
S500/2010/500
talk with commandonline guys they will l have a clue what went wrong....

they are experts, merc dealers are muppets
 


Prestige Motor Group is Hertfordshire's Premier INDEPENDENT MERCEDES BENZ SPECIALIST. We offer a service exceeding Main dealership expectations and HUGE savings on Main Dealership Prices. WE BEAT ANY GENUINE QUOTE! Prestige Motor Group pride ourselves on delivering excellent customer service as we believe the customer and the Car deserve the best.
Tel: 01462 672458www.prestigemotorsofhertfordshire.co.uk/
Top Bottom