cruise control on 99 c250 td fault

laurence

Senior Member
Joined
Jun 1, 2009
Messages
52
Reaction score
0
Your Mercedes
c202 250td
Hi All,
has anyone any ideas why my c250td estate 202 auto cruise only works at low speed (only works up until 35 mph).Car has done 135k and only just bought it.Also when starting up (hot or cold) engine will not rev (traction light comes on) at first when driving,after 2 minutes it works and revs just fine.This cannot be normal can it?Just for ref,the car has had non return valve by the main dealers a few years ago and starts first time,then runs like a dream.
 

JEZ.S320L

Active Senior Members
Joined
Aug 18, 2007
Messages
2,804
Reaction score
3
Location
Costa Calida, Spain
Website
www.latorreonline.es
Your Mercedes
Lincoln Navigator and a S320L Business Edition
Hi All,
has anyone any ideas why my c250td estate 202 auto cruise only works at low speed (only works up until 35 mph).Car has done 135k and only just bought it.Also when starting up (hot or cold) engine will not rev (traction light comes on) at first when driving,after 2 minutes it works and revs just fine.This cannot be normal can it?Just for ref,the car has had non return valve by the main dealers a few years ago and starts first time,then runs like a dream.

Hello and welcome to the Forum.

First things first. Concerning the CC issue, have you checked that the tyre sizes are correct for the vehicle?

As for the engine problems, others with more knowledge about engines will be along soon.
 

turbopete

Senior Member
Joined
Feb 4, 2009
Messages
14,204
Reaction score
328
Age
46
Location
Spennymoor
Your Mercedes
2010 '60' Ford Mondeo 2.0TDCi Zetec (sorry)
if the engine ecu thinks the traction control is operating, it will kill engine power and id guess not rev. as stated, check tyre sizes, also id consider checking the brake light switch. theyre a common problem for cruise control and cheap to replace.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Rust on the rear toothed wheel can do this on the speed sensor
 
OP
L

laurence

Senior Member
Joined
Jun 1, 2009
Messages
52
Reaction score
0
Your Mercedes
c202 250td
  • Thread Starter
  • Thread starter
  • #5
re cruise control

Malcom,
Thanks you for reply,would you please be kind enough to let me know where the sensor is located?Kind regards Laurence
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
OP
L

laurence

Senior Member
Joined
Jun 1, 2009
Messages
52
Reaction score
0
Your Mercedes
c202 250td
  • Thread Starter
  • Thread starter
  • #7
cruise control problems

Malcom,
you are very knowlegable,will try your sugestion and let you know of my sucess.Good response to my problem already,thanks again for your time. Kind regards Laurence
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
If you do not have any luck after that then other things can be checked
 


Mercedes-Benz Servicing, repairs, engine and diagnostics
Wayne Gates - Mercedes-Benz, Unit F3, Phoenix Industrial Estate, Rosslyn Crescent, Harrow, Middlesex, HA1 2SP
Tel: 020 8863 9233
Established for 20 years all vehicles washed and vacuumed.
Top Bottom