cruise control

Moppy's Merc

New Member
Joined
Jul 20, 2009
Messages
6
Reaction score
0
Hi,

Two little problems if you can help,

Park distance sensor OSF goes of on its own, to the point I turn them off. Is it maybe a new sensor?

Also my cruise controll will only hold for about 5 min then drops out. if I try to set it again it will hold for seconds only. If i switch it of and on again then it will repeat the 5 min again. Any thoughts?

Cheers,

Paul.
 

rpe2

Senior Member
Joined
Sep 25, 2006
Messages
2,866
Reaction score
3
Age
44
Location
Silchester
Your Mercedes
His: 2018 E220 d; Hers: 2016 SMAX
Ah, your other problems...

Parking sensor: Yes new sensor req't. Plugging into a star computer will tell which one.

Cruise control, not my bag, sorry.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
341
Age
87
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
I use a flat panel on a shaft for finding the faulty sensor, just by covering each one in turn.


CC faults are not easy,,what is the car please
 
OP
M

Moppy's Merc

New Member
Joined
Jul 20, 2009
Messages
6
Reaction score
0
  • Thread Starter
  • Thread starter
  • #4
Thanks for sensor replies.

The cars an April 2000 320CDi estate.

Paul.
 
OP
M

Moppy's Merc

New Member
Joined
Jul 20, 2009
Messages
6
Reaction score
0
  • Thread Starter
  • Thread starter
  • #6
Thanks for sensor replies.

The cars a 2000 320CDi estate.

I also now has a drain on the battery! as I don't use the car every day it can sit for two to three at a time. it might start once but not when I get to my destination. I did buy a new battery thinking it was this, but its not. All these things have happened in the last month and I've only had it Three!

Thanks,

Paul.
 

MB TECH WARRINGTON

Senior Member
Joined
Jun 2, 2008
Messages
572
Reaction score
0
Thanks for sensor replies.

The cars a 2000 320CDi estate.

I also now has a drain on the battery! as I don't use the car every day it can sit for two to three at a time. it might start once but not when I get to my destination. I did buy a new battery thinking it was this, but its not. All these things have happened in the last month and I've only had it Three!

Thanks,

Paul.


Not startting at your destination sounds like a charging fault as opposed to draw,
 

Rockhopper1

Active Member
Joined
Jul 23, 2009
Messages
43
Reaction score
0
Ive known incorrect bulbs cause cc faults, ie double element as opposed to single

I've got a similiar fault on my cruise control aswell. Excuse my ignorance but does this mean a car fitted with a side light/brake light bulb instead of just one or the other?

If anyone has any info it would be much appreciated

Thanks
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
341
Age
87
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
What is the car please
 

Rockhopper1

Active Member
Joined
Jul 23, 2009
Messages
43
Reaction score
0
Sorry, Its the same car as above. E320 CDI Elegance on a X plate year 2000

Thanks Sam
 

Avantgarde Automotive, Mercedes-Benz and SLR McLaren specialists. Service, repairs, diagnosis and motorsport preparation.
Unit 14 Hither Green Trading Estate, Clevedon, Somerset, BS21 6XU Tel: 01275 217270 Email:steve@avantgarde-automotive.co.uk
www.avantgarde-automotive.co.uk
Top Bottom