eglington

eglington

New Member
Joined
Jul 27, 2009
Messages
3
Reaction score
0
Iput my mercedes 2000 saloon into a local garage with the following defect: ABS light remains on whilst motoring my speedometer is also defective(could they be related? The garage diagnostics equipment couldn't detect the problem. Anyone ever had a similar problem rectified?
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Hello and welcome,,your car needs to be plugged into a STAR MB test set,,most indies have one.

Yes the fault is causing both faults,,you have lost a speed signal

If you give the area where you live, maybe we can recomend someone for you
 
OP
E

eglington

New Member
Joined
Jul 27, 2009
Messages
3
Reaction score
0
  • Thread Starter
  • Thread starter
  • #3
Mercedes 2000 eglington

Thanks Mark,


I live in Skelmorlie North Ayrshire.
 
OP
E

eglington

New Member
Joined
Jul 27, 2009
Messages
3
Reaction score
0
  • Thread Starter
  • Thread starter
  • #4
Thanks Malcolm,

I am in North Ayrshire.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Hello Mark,,why do you have to live there ;):D,,I have not got much,,but hopefully some others will come on with somewhere
 

Peter Best Insurance is a leading specialist in Mercedes-Benz insurance. All MBO members are eligible for exclusive rates on all our classic car policies.
Call now for our 'BEST' quote. Tel: 01376 573033
Top Bottom