Electric Power Steering Failure

rdmstewa

Senior Member
Joined
Oct 5, 2015
Messages
75
Reaction score
16
Location
Wakefield
Your Mercedes
2004 W203 C180K, 2014 E350cdI, 1976 Triumph 2500S Estate
Hi Folks - I have a W207 E350 Coupe with 43k on the clock. T'other night I reversed out of a car park space and as I went to go forward the PAS failed and a red warning message "Power Steering Failure, see owner's handbook" or something like that appeared. And the steering became very heavy. In the time it took me to contemplate driving 70 miles home with no power steering the PAS came back and the warning disappeared. And the car's been fine since then. I've seen a lot of posts on here about PAS issues, but none of them mention it fixing itself. I've got the beast booked in with my local independent to put it on Star, but that can't be done until later this week. I'm curious to know if anyone else has had this intermittent issue?
Many thanks
Malc
 

Blobcat

Moderator
Joined
Feb 8, 2006
Messages
30,772
Reaction score
16,163
Location
Grange Moor
Your Mercedes
R171 SLK280, Smart R451, Land Rover 110 County SW, 997 C2S, R1250 GSA TE 40th, CBR600FP
What condition is the battery in?
 
OP
rdmstewa

rdmstewa

Senior Member
Joined
Oct 5, 2015
Messages
75
Reaction score
16
Location
Wakefield
Your Mercedes
2004 W203 C180K, 2014 E350cdI, 1976 Triumph 2500S Estate
  • Thread Starter
  • Thread starter
  • #3
What condition is the battery in?
Hi Blobcat - looks like you're local to me. I use German Autocare in Wakefield and the car was in a few days ago. I suspected the battery then (another issue which they diagnosed as the fusebox) and I asked them to test it - they didn't tell me I needed a new one then. I don't have a meter so I can't test it myself. But I suspect it's the original, maybe it's time for a new one...
 

Blobcat

Moderator
Joined
Feb 8, 2006
Messages
30,772
Reaction score
16,163
Location
Grange Moor
Your Mercedes
R171 SLK280, Smart R451, Land Rover 110 County SW, 997 C2S, R1250 GSA TE 40th, CBR600FP
Hi Blobcat - looks like you're local to me. I use German Autocare in Wakefield and the car was in a few days ago. I suspected the battery then (another issue which they diagnosed as the fusebox) and I asked them to test it - they didn't tell me I needed a new one then. I don't have a meter so I can't test it myself. But I suspect it's the original, maybe it's time for a new one...
Have a look on the battery terminal, there will be a 4 digit code - it’s the week and year of manufacture.

You might have an option somewhere to see battery voltage. If you’re about this way, I’ve a meter and a Foxwell Pro code reader.
 
OP
rdmstewa

rdmstewa

Senior Member
Joined
Oct 5, 2015
Messages
75
Reaction score
16
Location
Wakefield
Your Mercedes
2004 W203 C180K, 2014 E350cdI, 1976 Triumph 2500S Estate
  • Thread Starter
  • Thread starter
  • #5
Thanks Blobcat. I'll see how we do, and I may turn up on your doorstep! I've got a code reader, but no knowledge on how to use it - or even the ability to plug it in, as I'm getting on a bit!
 
OP
rdmstewa

rdmstewa

Senior Member
Joined
Oct 5, 2015
Messages
75
Reaction score
16
Location
Wakefield
Your Mercedes
2004 W203 C180K, 2014 E350cdI, 1976 Triumph 2500S Estate
  • Thread Starter
  • Thread starter
  • #6
Thanks Blobcat. I'll see how we do, and I may turn up on your doorstep! I've got a code reader, but no knowledge on how to use it - or even the ability to plug it in, as I'm getting on a bit!
Update - I went to German Autocare and they put it on Star. Diagosed a "communication error" but that doesn't really tell us anything. Hasn't thrown the error since. I spoke to the Carshop where I bought the car and they've agreed to fit a new battery FOC. The one that's in there is eight years old. So we'll see what happens after that's been done.
 
OP
rdmstewa

rdmstewa

Senior Member
Joined
Oct 5, 2015
Messages
75
Reaction score
16
Location
Wakefield
Your Mercedes
2004 W203 C180K, 2014 E350cdI, 1976 Triumph 2500S Estate
  • Thread Starter
  • Thread starter
  • #7
Hi Folks

Many thanks for the advice. Car's got a new battery now and all seems to be ok!
 

moj91

Senior Member
Joined
Jul 12, 2013
Messages
390
Reaction score
81
Location
Northamptonshire
Your Mercedes
W213 E400d-T, W204 C250CDI-T, W220 S320CDI (AMG Kit), W168 A170CDI, W210&W124 OM606...
Similar symptoms can occur when the ABS module is on its way out - loss of PAS, as well as ABS/ESP light on.
 
OP
rdmstewa

rdmstewa

Senior Member
Joined
Oct 5, 2015
Messages
75
Reaction score
16
Location
Wakefield
Your Mercedes
2004 W203 C180K, 2014 E350cdI, 1976 Triumph 2500S Estate
  • Thread Starter
  • Thread starter
  • #9
Thanks! Well, nothing untoward has happened since the new battery...
 


Prestige Motor Group is Hertfordshire's Premier INDEPENDENT MERCEDES BENZ SPECIALIST. We offer a service exceeding Main dealership expectations and HUGE savings on Main Dealership Prices. WE BEAT ANY GENUINE QUOTE! Prestige Motor Group pride ourselves on delivering excellent customer service as we believe the customer and the Car deserve the best.
Tel: 01462 672458www.prestigemotorsofhertfordshire.co.uk/
Top Bottom