Electrical boot lid failure for 04 E270

mighty magpie

New Member
Joined
Feb 16, 2009
Messages
6
Reaction score
0
Hi
I'm getting 3 malfunctions on the dash. both number plate lights & the 3rd brake light failure. The boot lid wont open on the key or with the button on the drivers door. along with the boot interior lights. i was thinking it maybe a fuse/relay problem?
Has anyone experienced this that can assist?
Thanks
 

Cole@MBS

Forum Supporter
Authorised Forum Supporter
Joined
Dec 1, 2008
Messages
13,702
Reaction score
945
Age
53
Location
Southampton
Website
www.mbssouthampton.co.uk
Your Mercedes
124 300 CE 24 Coupe, C220CDI, Porsche 911 4s, Dolomite sprint,
Sounds like a wiring fault, seen a few now!!
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
365
Age
89
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Broken wires in the hinge area if the boot has been used alot,,the key will open it
 

Alex Crow

Senior Member
Joined
Jul 9, 2009
Messages
10,677
Reaction score
46
Location
Super Suffolk
Your Mercedes
W169, W124, w202, W203, KTM 250 EXC, VW T25 camper and a Polo in a pear tree
agree with the above experts. it will be the main earth cable, possibly others.
 

discover

Member
Joined
Jul 12, 2009
Messages
15
Reaction score
0
Yes definitely broken wires on the n/s hinge. Done one before! Agree use key to open boot.
 
OP
M

mighty magpie

New Member
Joined
Feb 16, 2009
Messages
6
Reaction score
0
  • Thread Starter
  • Thread starter
  • #6
Thanks for all your swift replies. I will get that checked out now.
 
OP
M

mighty magpie

New Member
Joined
Feb 16, 2009
Messages
6
Reaction score
0
  • Thread Starter
  • Thread starter
  • #7
Yes definitely broken wires on the n/s hinge. Done one before! Agree use key to open boot.
Sound Advice! Problem sorted. A brown wire nipped underneath the n/s hinge.
Thanks:)
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
365
Age
89
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Thanks for posting back with a good answer :D:D
 

NevShaw

New Registration
Joined
Jan 16, 2015
Messages
1
Reaction score
0
Location
Chester UK
Your Mercedes
E 270 CDI 2005
Thanks

Thanks for your help.
I thought that would be the case (broken wire) and you have confirmed it
Nice to no where the wires are (n/s) as i would have started on the other.
Again thanks
 

snibble

New Member
Joined
Nov 13, 2007
Messages
4
Reaction score
0
another satisfied customer

Just to say I had exactly the same issue with my e280 and having read this thread I have also rejoined my previously severed brown lead , thus restoring functionality. Many thanks to all for the advice above, I already had complete faith in Alex Crow who does the jobs that I can't do for me but also to the other posters who added weight to the argument and speedily pointed me in the right direction. 2 hours of very satisfying work, not including time spent getting stuck at an uncomfortable angle in the boot!
 
Last edited:

AIB understand your special Mercedes deserves a special insurance policy. We have a refreshing attitude to insuring high performance, modified, imported or classic and vintage cars and deal with the UK’s leading insurers. We offer discounts for length of ownership, where the vehicle is kept overnight and limiting the mileage and can also cater for those clients who need higher mileage and business use. To obtain a quotation please call the team on 02380 268351 or visit us atAIB Insurance
Top Bottom