Gear box just done a strange thing, advice please?

G-a-r-y

Senior Member
Joined
Feb 7, 2006
Messages
556
Reaction score
4
Location
Bristol
Your Mercedes
S211 320 CDi, SLK 200 R171.
I just popped out in my car which hasn't been used for a week or two, it stayed in low gear and wouldn't change up. I tried to force an up change by using tip function but that didn't work. I put my foot down and reved a little higher-it wouldn't go above 3000rpm. I held the accelerator down and after 30-40 secs the revs picked up and then changed gear as normal. I stopped and restarted and all was normal. Car is E320 CDi five speed with tip. Battery was up, box was serviced last year. 90 k miles.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
I just popped out in my car which hasn't been used for a week or two, it stayed in low gear and wouldn't change up. I tried to force an up change by using tip function but that didn't work. I put my foot down and reved a little higher-it wouldn't go above 3000rpm. I held the accelerator down and after 30-40 secs the revs picked up and then changed gear as normal. I stopped and restarted and all was normal. Car is E320 CDi five speed with tip. Battery was up, box was serviced last year. 90 k miles.

Do not worry about that at this point in time,,just a low voltage starting blip can do this. Just see how it goes,,starting again aways cures them
 

Blobcat

Moderator
Joined
Feb 8, 2006
Messages
30,170
Reaction score
15,550
Location
Grange Moor
Your Mercedes
R171 SLK280, Smart R451, Land Rover 110 County SW, 997 C2S, R1250 GSA TE 40th, CBR600FP
When they are cold they can and do hold onto lower gears for longer to aid warming up, it maybe this that caused the hold.
 
OP
G-a-r-y

G-a-r-y

Senior Member
Joined
Feb 7, 2006
Messages
556
Reaction score
4
Location
Bristol
Your Mercedes
S211 320 CDi, SLK 200 R171.
  • Thread Starter
  • Thread starter
  • #4
When they are cold they can and do hold onto lower gears for longer to aid warming up, it maybe this that caused the hold.

I've had the thing for years and it's never done it before, even at -4c in the winter. Today is warm @13+c.
 

rich.g.williams

Senior Member
Joined
Oct 25, 2009
Messages
450
Reaction score
0
Location
North Wales
Your Mercedes
C200 CDI Avantgarde SE Auto May 2004 Sports Pack
3000 rpm is a magic number yes? engine limp home maf sensor

or a bad contact, sticking solenoid/speed sensor in the transmission

read error codes (event will be logged in engine or transmission computer) or forget it until if it happens again
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
The gear boxes only have very small memories when my 129 did this and needed a re start clearing the codes on STAR it did not do it again for the rest of the time that I owned it

Many do not ever solve this odd fault
 

Xtractorfan

Senior Member
Joined
Nov 16, 2007
Messages
6,084
Reaction score
156
Your Mercedes
S class
An oil and filter change wouldnt do the box any harm and may even improve matters..
 
OP
G-a-r-y

G-a-r-y

Senior Member
Joined
Feb 7, 2006
Messages
556
Reaction score
4
Location
Bristol
Your Mercedes
S211 320 CDi, SLK 200 R171.
  • Thread Starter
  • Thread starter
  • #8
I had the box serviced last year by a auto gear box repairer in Bristol, rather than the main agents even though they were more expensive. I called the main agents (Sytner) they want £85 for one hour to diagnose the fault. They did say that it sounds like it had gone in to limp mode.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
The limp home mode is when it is locked into say 2nd gear,,is it ok now or has it done it since
 
OP
G-a-r-y

G-a-r-y

Senior Member
Joined
Feb 7, 2006
Messages
556
Reaction score
4
Location
Bristol
Your Mercedes
S211 320 CDi, SLK 200 R171.
  • Thread Starter
  • Thread starter
  • #10
I tried the car today (after leaving it) and it was perfect. I think I'll leave it this side of Christmas. I'll see if it does it again and for what reason. It's due a service so I wonder if they'll read faults codes as part of the service.(main agents)
 
OP
G-a-r-y

G-a-r-y

Senior Member
Joined
Feb 7, 2006
Messages
556
Reaction score
4
Location
Bristol
Your Mercedes
S211 320 CDi, SLK 200 R171.
  • Thread Starter
  • Thread starter
  • #11
Just used the car and it went into limp mode again, this time I noticed more. It only had second gear and did rev fully. The dash gear indicator box was lite up but no gears were showing. I locked and unlocked a couple of times and then it was OK.
I've booked it into an Indy in Bristol, anyone like to hazard a guess as to whats wrong.
 

Alex Crow

Senior Member
Joined
Jul 9, 2009
Messages
10,677
Reaction score
40
Location
Super Suffolk
Your Mercedes
W169, W124, w202, W203, KTM 250 EXC, VW T25 camper and a Polo in a pear tree
does it only happen from cold starts? how old is the battery?
 
OP
G-a-r-y

G-a-r-y

Senior Member
Joined
Feb 7, 2006
Messages
556
Reaction score
4
Location
Bristol
Your Mercedes
S211 320 CDi, SLK 200 R171.
  • Thread Starter
  • Thread starter
  • #13
Two year old Varta, It starts quickly. I left it running for a while just to make sure. After restarting it was still in limp. I will check the battery voltage this morning, before and after starting.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
It would be nice to get to the bottom of this fault,, as before my 99 SL could lock up if I moved the gear shift back one notch even when very hot, and a perfect battery and the only way to get it into top was to turn off,,it never did it when left in top.

This gets me thinking,,how about the circuit that locks the boxes in a low gear, could this be the fault and I believe this is controlled by the engine temp, and CAN controlled.

I do know that on cars 98-2001 the connector on the on the box ECU can have poor connections on the 2 end CAN BUS connections. Cleaning with a good non drying cleaner has worked for some cars here.

This faulty or poor connection on the plug is a fault in WIS
 
OP
G-a-r-y

G-a-r-y

Senior Member
Joined
Feb 7, 2006
Messages
556
Reaction score
4
Location
Bristol
Your Mercedes
S211 320 CDi, SLK 200 R171.
  • Thread Starter
  • Thread starter
  • #15
Telly, your getting warm. Prior to taking the car over I checked the battery volts 11.85
I connected jump leads and achieved 13.5v, Reset the car but still in limp mode.
I took it to the Indy in limp who put it on Star/fault reader; can't read gearbox control unit???
The guy said my model was not affected by low voltage. He checked the loom that runs from box to control unit, mentioning a possible oil/leak fault. Mine was clean and dry on the top end (under bonnet)
When he took the box covers down oil was leaking out of the loom/wiring plug which is most likely the fault. They said to fit a new modified connector and seal and refill the box with oil £60 ish. It's booked in for Tuesday. I'm pleased with that and said I'll mention his garage.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Good,,we are getting there,, just wash the ECU out with lighter fuel and dry it,, now do use that non drying contact on the plug and socket,,it is harmless and spray plenty on and in,, the end 2 CAN connections are the ones that must be good
 
OP
G-a-r-y

G-a-r-y

Senior Member
Joined
Feb 7, 2006
Messages
556
Reaction score
4
Location
Bristol
Your Mercedes
S211 320 CDi, SLK 200 R171.
  • Thread Starter
  • Thread starter
  • #17
It's oil free and clean at the top (ECU) What is the "2 CAN" I thought it was a kind of colourful bird.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
It's oil free and clean at the top (ECU) What is the "2 CAN" I thought it was a kind of colourful bird.

You only have the one multi connector going into the ECU that is the plug that needs the contacts to be cleaned on,,even if it looks OK
 
OP
G-a-r-y

G-a-r-y

Senior Member
Joined
Feb 7, 2006
Messages
556
Reaction score
4
Location
Bristol
Your Mercedes
S211 320 CDi, SLK 200 R171.
  • Thread Starter
  • Thread starter
  • #19
I'll get my pair of magnifying glasses and have a look at that over the weekend.
Will it log a fault if I don't turn the ignition on?
 

Comand Online Ltd is a specialist supplier of Mercedes Navigation Disks, Phone & Bluetooth, iPod, DAB, CD and other COMAND retrofit parts to enhance your vehicle.www.comandonline.co.uk
Top Bottom