Gearbox puzzle

silverhorse

Senior Member
Joined
May 2, 2008
Messages
96
Reaction score
0
Location
Blackpool UK
Your Mercedes
300E/1998/3000diesel
My 3 litre turbo diesel 1998 auto has an intermittent fault. If I drive downhill off the drive it does on occasion go into neutral mode with the gear lever still in drive. This seems to happen only when driving forward. If I then move into park and then back into drive the car is fine. This occurs on odd occasions but never in reversing.The fluid in the gearbox has been checked by my Indie and is at the correct level.Anyone else had this problem
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
The is a post on this for the 210,,it is said that if the battery is down on the voltage, then a starting blip could cause this.

On this year of car it is also worth cleaning the gearbox ECU connector
 
OP
S

silverhorse

Senior Member
Joined
May 2, 2008
Messages
96
Reaction score
0
Location
Blackpool UK
Your Mercedes
300E/1998/3000diesel
  • Thread Starter
  • Thread starter
  • #3
Thanks for the info. I was beginning to think that I may be the only one with this strange fault
 
A

abcdarko

Guest
All the doctors in my Country replace connector when changing the oil in the box, 5 euros part, happened that oil went thru the cables to the ECU, imagine the mess;)
Lever has separate ECU, have it STAR diagnosed
 


Chris Knott Insurance, see oursticky posts here!
www.ckinsurance.co.uk
Top Bottom