GL420 Airmatic Suspension Fault - intermittent

DrGekko

Member
Joined
Jul 25, 2013
Messages
10
Reaction score
0
Location
Walsall
Your Mercedes
GL/2006/420 CDI
I was so excited to receive my used GL420 which arrived on a trailer yesterday. It's 7 years old but the body and interior are in very good nick. Anyway, I took it out for a spin last night and to my dismay, whilst I was playing with the airmatic dial to check out the rise and lowering, the "suspension fault" warning light appeared on the dash and the body refused to move from its current height. Even worse was when I tried driving it - every tiny bump and the car would bounce awkwardly as if it were riding on large cobbles.

My bro-in-law explained this used to happen in the S-Class and apparently the ECU is super-sensitive and that perhaps it may have occured whilst bobbing up and down on the transporter. He suggested leaving it and that it would be ok in the morning.

True to his word, this morning it was fine and I drove to work with much satisfaction... I missed having a V8 and this reminds me of driving my Audi S4 a few years ago.

This afternoon I took the kids to a local park and the parking space is a large gravel open space. I wanted to check out driving the car with higher suspension so when I set the dial to raise, again, it just became locked at one height and the awful juddering occurred. I switched the engine off and back on a few times and kept adjusting the suspension dial until at last, it responded and I drove home.

I adjusted the dial whilst the car was on the drive at home and it's working fine (takes ****** ages though, like watching paint dry... my previous Discovery 4 raises and lowers within 5 seconds!!).

So Benz veterans??? Should I contact the specialist car dealer who's provided a "6 month warranty" and insist that this is inspected by Mercedes? Or am I doing something wrong and is there a simple remedy please?

Thanks!
 
Last edited:
OP
D

DrGekko

Member
Joined
Jul 25, 2013
Messages
10
Reaction score
0
Location
Walsall
Your Mercedes
GL/2006/420 CDI
  • Thread Starter
  • Thread starter
  • #2
anyone???? silence???
 

whitenemesis

Senior Member
Joined
Dec 21, 2006
Messages
17,978
Reaction score
32
Your Mercedes
CLS55 AMG '05
If its still under warranty it would be silly not to go back and ask them to check it out. Even if only to show you how to set it. I don't think for a minute you're doing anything wrong. Take advantage of the warranty whilst you have it!
 
OP
D

DrGekko

Member
Joined
Jul 25, 2013
Messages
10
Reaction score
0
Location
Walsall
Your Mercedes
GL/2006/420 CDI
  • Thread Starter
  • Thread starter
  • #5
If its still under warranty it would be silly not to go back and ask them to check it out. Even if only to show you how to set it. I don't think for a minute you're doing anything wrong. Take advantage of the warranty whilst you have it!

It's a 3rd party warranty and doesn't cover diagnostics. It only covers labour charges and parts upto a maximum of £1000 per claim. I will book it in with my local dealer in Walsall but no idea whether they charge to inspect.
 

whitenemesis

Senior Member
Joined
Dec 21, 2006
Messages
17,978
Reaction score
32
Your Mercedes
CLS55 AMG '05
Usual practice is to charge for diagnosis. You may have this waved if you then let them do the work. Of course the diag charge will have been incorporated in the final bill.
 

b786

New Registration
Joined
Feb 9, 2015
Messages
1
Reaction score
0
Location
Scotland
Your Mercedes
Gl420/2007
Did you get any further with this fault in the end?
 


Chris Knott Insurance, see oursticky posts here!
www.ckinsurance.co.uk
Top Bottom