Great Result BBA Reman have repaired my HK Amplifier, well its on the final soak test.

Submariner1

Senior Member
Joined
Sep 3, 2016
Messages
4,453
Reaction score
632
Location
Windsor Berkshire
Your Mercedes
CL500 2009 5.5
Just spoke to the technician.
They found the fault, basically good news there was no evidence of the dreaded and fatal water damage.
They found a few blown transistors, and the black dust was intermitantly shorting out a couple of circuits (where the blown componets were). They are pretty confident it was down to this black dust.
He thought it was brake dust and or combustion fumes. And it was conductive!

He reckoned on very humid days it could possibly become more conductive, and hence the failure.

Is brake dust conductive? is there any metalic compound in tne brake pad? Or is it just micro metal filings from the disc? Who knows but it seems logical.

OK its still fingers crossed, as its on its final soak test before being certified as good to go!
(And he warned me if it failed they would have to do more work, because they give a lifetime warranty on the Amplifier :) )

For those interested 5 day turn around, and you can drive the car with the without it. Other than tons of stuff cant be accessed eg all the Comand related vehicle stuff, like convenience settings on mirrors seats, alarm. Only thing I really missed apart from the music was really the reversing camera.

Very happy bunny :):):):)
Because £175 plus vat i.e £210 and £18 return carriage, is a huge reduction from £1,345 For a recon exchange MB unit.

In summary as long as you dont have water damage they can repair them.

Course I will repost once its installed.
 
OP
Submariner1

Submariner1

Senior Member
Joined
Sep 3, 2016
Messages
4,453
Reaction score
632
Location
Windsor Berkshire
Your Mercedes
CL500 2009 5.5
  • Thread Starter
  • Thread starter
  • #2
Update
The amplifier just got signed off as repaired ... it past their post p-repair soak test! :):):):)

Total cost £245 including vat and postage

Extremely happy bunny. :):):):)
Obviously need to see it working in the CL and for a week or two.

Rather pleased as it means the CL 500 has not hammered me with any unexpected huge bills.
Well imo £245 is pretty manageable .. one can get that kind of number on a Golf.
 

Craiglxviii

Senior Member
Joined
Sep 6, 2015
Messages
15,870
Reaction score
4,917
Location
Cambs UK
Your Mercedes
W215 CL500 Motorway Queen; W251 R320L Familybenz, S211 E320 Avg Designo Edition now sadly missed.
Great news Peter!
 
OP
Submariner1

Submariner1

Senior Member
Joined
Sep 3, 2016
Messages
4,453
Reaction score
632
Location
Windsor Berkshire
Your Mercedes
CL500 2009 5.5
  • Thread Starter
  • Thread starter
  • #4
Great news Peter!

Thanks Craig.
And of course many thanks, to you, Alistair, Simon, Ray and Micheal for helping me with the info to have the courage to “have a go”
Nice to save £1155 or more if you had a garage take it out.

Sounds daft, but a big plus is she hasnt let me down with a big unforseen bill yet.
Especially as I didnt get her professionally checked out until after I bought her. I just got very lucky.

Note: I would however in future, always get a big Merc checked out by someone like Cole in future.

Obviously need to see it working in the car. :-/
but optimistic. :) ... but then anyone who runs an older 500 has to be ;)
 
OP
Submariner1

Submariner1

Senior Member
Joined
Sep 3, 2016
Messages
4,453
Reaction score
632
Location
Windsor Berkshire
Your Mercedes
CL500 2009 5.5
  • Thread Starter
  • Thread starter
  • #5
OK the Amp arrived back a day early.
No rain! :)

Re installed it.
And one very happy bunny.
It all seems to work perfectly.
The MOST stuff seems to work and other Comand, and the Logic 7 stuff / fades and balance.

As my problems were intermittant. One needs a little time, but it left broken and returned working so being a glass half full guy
One could say this is a great result for £242 incl VaT and Carriage. As UPS were a day late BBA refunded the collection fee. One cant ask for more than that.
Note my Amp was £1400 some are more than others.

:):):):)

Maybe the left tweeter is a tiny tiny bit more scratchy, so I will replace that for £27. - purely as distortion can wreck tweeters pretty quickly.
If I can figure out how those wires come off. Pulled like hell wont budge.

In fairness it could just be the standard of tweeter MB use and that CD. My comparison is based on Studio level Dynaudio speakers at home, imo the best money can buy ... so maybe its as good as new. Luckily the expensive mid range sound perfect. And as it uses the same channel and wires one can be sure the amp has been repaired properly.
Nice to save £1,150. :)

Again many thanks to all those, who helped me re the Amp and getting it out.
 
Last edited:
OP
Submariner1

Submariner1

Senior Member
Joined
Sep 3, 2016
Messages
4,453
Reaction score
632
Location
Windsor Berkshire
Your Mercedes
CL500 2009 5.5
  • Thread Starter
  • Thread starter
  • #6
Update for those considering BBA.
My audiophile friend, (note his home sound system cost a whopping £22K) felt the left tweeter occaisionally wasnt as good as the right. I.e. the odd high note slightly distorted (probably most drivers would not even notice it).

He felt it was occaisionally displaying very slight, but classic interference damage symptoms, easy remedy ... replace it at £27. its ordered.

He also pointed out that the left tweeter shares the same channel as the left mid range, and as the mid range sounds perfect. Well HK perfect Lol :)
In his opinion that proves BBA repaired the channel properly, and tweeters are very easily damaged by distortion.
Note he was so confident, he said if I changed it , he would bet the £27 cost , that it would cure it.

The other issue with radio interference. I am convinced is purely down to dashcam interference, either the dashcam itself ... plonked exactly on the FM ariel in the rear screen, and also extremely close to the FM aerial amplifier in the roof, and or possibly the self installed USB charger converter 12v to 5v USB.
Note when the dashcam is not powered there is absolutely no interference.
I spoke to BBA who interestingly pointed out that when I change presets even if the dashcams are on, it selects the right frequency ... proved by unplugging the USB dashcam cables and bingo perfect radio.
He felt the tuner was working perfectly, but the interference was so bad the resultant signal was so weak that the tuner correctly refused to name it, and thus be ready to select as a preset. That seems logical to me.

In summary BBA really did a great job ... and IMO you can send it there for repair with total confidence.
 


Specialist Classic Parts suppliers
SLS Im- & Export Handelsges.mbH, Industriestrasse 2 - 4, D-22885 Barsbuttel (bei Hamburg)
Tel. +49 (0)40 656 939-0, Fax +49 (0)40 656 939-399
Visit our website atwww.sls-hh-shop.deto view our comprehensive catalogue of parts for:
190SL (R121), 230 - 280SL (R113), 280 - 500SL/C (R/C107)
Good English spoken and friendly service to discuss your requirements.
Top Bottom