Guess the job on this beautiful 129

fast28

Senior Member
Joined
Nov 8, 2010
Messages
146
Reaction score
3
Location
Glos
Your Mercedes
SL55-conversion (R129) & CL63 AMG (W216)
What are the indications the evaporator requires replacing, does it leak into the passenger footwell?

The A/C in my R129 doesn't work, its had a new condenser and the system refilled. STAR diagnostics reports that the electromagnetic clutch on the compressor is not engaging but I wonder if this is the cause or the effect of something else?
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,074
Reaction score
328
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Loosing gas is the main one, you can do a dye check, if nothing shows up for a leak in the engine bay, that just leaves the evaporator
 

mikestrivens

Senior Member
Joined
Nov 21, 2008
Messages
2,715
Reaction score
146
Location
Stockport
Your Mercedes
1995 W124 320TE, 1998 R129 SL500, 2016 Triumph Tiger 800 XCx
As above, on my W124 it was a slow leak that wasn't manifest in the condenser, pipework, valves etc in the engine compartment. That just left the evaporator which was covered in dye when SPR Autos removed it.
 

mikestrivens

Senior Member
Joined
Nov 21, 2008
Messages
2,715
Reaction score
146
Location
Stockport
Your Mercedes
1995 W124 320TE, 1998 R129 SL500, 2016 Triumph Tiger 800 XCx
What are the indications the evaporator requires replacing, does it leak into the passenger footwell?

No it comes out as a gas.

The A/C in my R129 doesn't work, its had a new condenser and the system refilled. STAR diagnostics reports that the electromagnetic clutch on the compressor is not engaging but I wonder if this is the cause or the effect of something else?

The clutch won't engage if the system is empty or low on refrigerant.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,074
Reaction score
328
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
What are the indications the evaporator requires replacing, does it leak into the passenger footwell?

The A/C in my R129 doesn't work, its had a new condenser and the system refilled. STAR diagnostics reports that the electromagnetic clutch on the compressor is not engaging but I wonder if this is the cause or the effect of something else?

The last time I was in MBS they had a car where the clutch would not engage, it turned out to be the wire was broken on the compressor.

So it all pressures good, something to look for.
 

fast28

Senior Member
Joined
Nov 8, 2010
Messages
146
Reaction score
3
Location
Glos
Your Mercedes
SL55-conversion (R129) & CL63 AMG (W216)
A/C diagnostics reports pressure within spec but there is a recurring fault code for the electromagnetic clutch. It will not activate when instructed to by STAR. The coil is showing continuity with no breaks but when I try to activate the clutch with a 12v power source it pops the fuse. I think the compressor is goosed!:-(
 

M80

Senior Member
Joined
Jan 21, 2006
Messages
4,447
Reaction score
1,327
Location
Derbyshire
Your Mercedes
Viano 639, 651 5sp Auto.
Nope, i needed 6 8mm washered screws which were missing when i started, trick is, when you take a panel of, you tape the screws to the inside of said panel, you cant go wrong that way..............it takes a tad longer but you no what screws go where.......

Good tip, my way has been to remove what ever and put the screws back where they came from. Not always possible though.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,074
Reaction score
328
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
A/C diagnostics reports pressure within spec but there is a recurring fault code for the electromagnetic clutch. It will not activate when instructed to by STAR. The coil is showing continuity with no breaks but when I try to activate the clutch with a 12v power source it pops the fuse. I think the compressor is goosed!:-(

No if STAR activates it it is what ever drives the compressor, if it was shot it could not run, a relay maybe
 

WG M-B

Senior Member
Authorised Forum Supporter
Joined
Dec 5, 2010
Messages
3,105
Reaction score
6
Location
North west london
Your Mercedes
C63 Wagon in black
If the evaporator is leaking you will see the uv dye leaking from the ac drains usually
 

DSB SL AMG

Senior Member
Joined
Jan 14, 2010
Messages
1,873
Reaction score
5
Location
Cheshire
Your Mercedes
300SL (R129 1992 Pre-Facelift), Volvo V70 D5 SE Auto
Reading this...so glad my R129 does not have aircon:D
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,074
Reaction score
328
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Reading this...so glad my R129 does not have aircon:D

That is not quite right, if you have a car with air con and the evaporator fails, then we have a car like yours ;)

I am only teasing ;)
 

Frontstep

Senior Member
Joined
Apr 22, 2007
Messages
7,821
Reaction score
1,630
Your Mercedes
T210 320cdi
Being a fully qualified MB tech I assumed from the pictures the rear brakes were squeaking and you were quiet. :D
 


Chris Knott Insurance, see oursticky posts here!
www.ckinsurance.co.uk
Top Bottom