1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help Multiple error messages mercedes independent is stumped !!

Discussion in 'Electrics, Vacuum, Ignition and ECU' started by monet208, Oct 29, 2012.

  1. monet208

    monet208 Active Senior Members

    Messages:
    62
    Likes Received:
    1
    Joined:
    Jul 18, 2008
    Location:
    yorkshire
    Hi
    Mercedes C180K coupe 2003
    On starting mutiple error messages come up SRS ,ERS, alternator -visit workshop light sensor,coolant-visit workshop
    Been happening on/off for months - otherwise car dives fine and done a few long trips with no problems
    These messages go off after a few minutes but light sensor and coolant remained so went on STAR at independent mercedes who replaced light sensor and coolant fan ,faults cleared but they both come on again
    Ocassionally wiper and windows stop working but turn ignition on/off they work fine
    Alternator tested and is fine and we have no battery drain
    Independent put it on STAR again today and said front SAM ok but still getting coolant,light sensor and alternator fault messages- also said slight flickering on instrument cluster but I cannot spot that
    Independent now advise going to mercedes dealer as may heve been up to date STAR
    Obiviously being driven mad by this !! |And being an OAP do not have a bottomless pocket so please any advice welcome
     
  2. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    310
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    I can only guess that the SAM is faulty and it cannot find these things till the priority buses have died down, any water around would be a clue maybe
     
  3. OP
    monet208

    monet208 Active Senior Members

    Messages:
    62
    Likes Received:
    1
    Joined:
    Jul 18, 2008
    Location:
    yorkshire
    Thanks television

    Thanks for the SAM suggestion -the strange thing is the independent said it seemed ? ok but will check the water clue myself
    Before I get the SAM replaced I have been told by an owner it may be
    "can system all corroded at terminals in side near foot well "
    Not sure what can stands for but assume its some wiring somewhere ?
    If I can check these out before getting the SAM replaced would you be so kind to tell me where to look for these since " in side near foot well " is a little vague for a non mechanic !
     
  4. Alex Crow

    Alex Crow Senior Member

    Messages:
    10,677
    Likes Received:
    34
    Joined:
    Jul 9, 2009
    Location:
    Super Suffolk
    Your Mercedes:
    W169, W124, w202, W203, KTM 250 EXC, VW T25 camper and a Polo in a pear tree
    If it were corroded CAN wires, any good specialist ought to have found it by now.

    My guess here might be front SAM too, but internet guesses are hard!
     

Share This Page