1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

HELP PLEASE. Strange electrical problem

Discussion in 'Electrics, Vacuum, Ignition and ECU' started by MikeVernon, Nov 1, 2012.

  1. MikeVernon

    MikeVernon Member

    Messages:
    23
    Likes Received:
    1
    Joined:
    Apr 9, 2011
    Your Mercedes:
    slk320 2002 3.2
    The screenwasher pump on my SLK has stopped working after the car has been unused for a long time. The pump motor if fine, but the electrical feed to it has a strange problem. I've unplugged the two wires which connect to the motor. One is the earth, and the other has a voltage reading of 4.31v all the time, whether the ignition swich is on or off! Operating the screenwasher control makes no difference to this reading.

    Any ideas? Does the screenwasher circuit contain a relay? Does the feed to the pump motor come directly from the switch on the steering column? I'm thinking that if it does then I can connect a wire directly from the switch to the motor to eliminate any wiring fault between the two.
     
  2. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    274
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    You just cannot go adding wires as these things have ECUs that control things.

    Give me a reminder later in tonight and I will see what I can find
     
  3. OP
    MikeVernon

    MikeVernon Member

    Messages:
    23
    Likes Received:
    1
    Joined:
    Apr 9, 2011
    Your Mercedes:
    slk320 2002 3.2
    Hi Chocolate
    That's what I'm trying to find out - is the screenwasher contolled by some kind of electronic module or does the power come directly from the switch? I realise that the same switch makes the wipers run for a few seconds as well as the pump, but the switch could still supply power directly. The wipers do operate when the switch is pushed, so presumably the switch itself is ok.
     
  4. OP
    MikeVernon

    MikeVernon Member

    Messages:
    23
    Likes Received:
    1
    Joined:
    Apr 9, 2011
    Your Mercedes:
    slk320 2002 3.2
    Hi Malcolm
    Did you manage to find out anything? I need to know where the feed to the screenwasher pump motor comes from. The wire is red/green.
     
  5. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    274
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    I forgot,,,:(:(:(:(:(:(:(:(:(:(:(:(:(:( please remind me this evening by just posting here and I will see it
     
  6. OP
    MikeVernon

    MikeVernon Member

    Messages:
    23
    Likes Received:
    1
    Joined:
    Apr 9, 2011
    Your Mercedes:
    slk320 2002 3.2
    Hi Malcolm

    Here is your reminder as requested!

    Thanks.

    Mike
     
  7. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    274
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    Please go to your other post and I can send the diagram to you
     

Share This Page