Help - w124 Coupe Seats Not Locking

H5LEV

Member
Joined
May 1, 2009
Messages
12
Reaction score
0
Location
Herts
Your Mercedes
w124 Coupe
Hi All,
I have a 1995 w124 coupe on which the front seats do not lock in place & the rear head rests do not drop when the button is pressed.

Remote central locking works fine.

Any ideas?

Thanks
H5LEV
 

rbarrett

Senior Member
Joined
Jan 12, 2008
Messages
66
Reaction score
0
Location
South Carolina, USA
I have a 124 (300D), 1995, that the drivers seat was not locking... it would arbitrarily take off upon starting and stopping:shock:... The seat is driven by a cable from a motor much like a speedometer cable. The cable drives the gear assembly that moves the seat.... The cable is either broken or has come out of the square socket it is supposed to fit in to. I was lucky and was able to put a small ball bearing into the socket to take up the room and keep the cable snug in both ends:p... either way, the seat has to come out and put on the bench to determine the problem:neutral:... PITA.....
Not sure about the headrests... Fuse??
 

meanie

Senior Member
Joined
May 7, 2008
Messages
581
Reaction score
0
Location
Oxon
Sounds like a vacuum leak somewhere-do the h/lamp adjusters still work?
You'll need one of these really.....
http://www.mityvac.com/pages/products_hvpk.asp
.....& a schematic diagram of the vacuum circuit to make it easier.
Check the supply from the engine to the reservoir (behind the sh#t guard under the drivers wing).
Can you hear a gentle hissing anywhere with the engine running?
I can help you with the headrest parts if needed,but the fault probably lies elsewhere.
 

kth286

Senior Member
Joined
Nov 4, 2002
Messages
3,067
Reaction score
2
Your Mercedes
E320 Coupe 95
You know doors have to be shut and engine running ??????????
 

franksm

Active Member
Joined
Apr 21, 2006
Messages
39
Reaction score
0
Website
mx5ireland.com
Did you manage to find diagrams for the vacuum system ?

I have messed up my seats in the same way - the economy gauge wasn't plumbed in on my car (no idea why), so I spliced into a purple vacuum tube behind the dash with a T. However, this must go to a check-valve or something, because the econo-gauge didn't move the way it should (stuck at 1/2 way).

So, I fixed the splice I made, and plumbed the econo-gauge into one of the non-valve lines behind the firewall, beside the fusebox. Success ! The econo-guage works as it should. However now my seatbacks don't lock in place. Everything else is working fine.

I think the splice-and-repair I made on the purple line needs to be re-done...
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded


Mercedes-Benz Servicing, repairs, engine and diagnostics
Wayne Gates - Mercedes-Benz, Unit F3, Phoenix Industrial Estate, Rosslyn Crescent, Harrow, Middlesex, HA1 2SP
Tel: 020 8863 9233
Established for 20 years all vehicles washed and vacuumed.
Top Bottom