Help

Tonymne

New Member
Joined
Aug 3, 2022
Messages
2
Reaction score
0
Your Mercedes
C250
Hi new to the group I have a Mercedes c250 estate had a new engine fitted and my heater/ac control unit is not working was told I needed a new one I’ve got another one and still not working does anyone know if it needs coding in been told there is power to the unit but it’s not turning on and there is no blown fuses any help would be appreciated
 

Attachments

  • 28DBF175-5CC9-4AE7-A468-21741B5F9C9F.jpeg
    28DBF175-5CC9-4AE7-A468-21741B5F9C9F.jpeg
    176.3 KB · Views: 2
OP
T

Tonymne

New Member
Joined
Aug 3, 2022
Messages
2
Reaction score
0
Your Mercedes
C250
  • Thread Starter
  • Thread starter
  • #2
Hi new to the group I have a Mercedes c250 estate had a new engine fitted and my heater/ac control unit is not working was told I needed a new one I’ve got another one and still not working does anyone know if it needs coding in been told there is power to the unit but it’s not turning on and there is no blown fuses any help would be appreciated
 

Attachments

  • A6A0B0F8-118F-44C2-9F11-C3BB799E1A81.jpeg
    A6A0B0F8-118F-44C2-9F11-C3BB799E1A81.jpeg
    176.3 KB · Views: 2

brandwooddixon

Senior Member
Joined
Jul 31, 2006
Messages
3,470
Reaction score
239
Location
Wolverhampton
Your Mercedes
CL500 Bluefficency 2012
Hi, welcome to the forum.
Although I can't help you, I'm sure that someone will come along who can, but first can you provide more information regarding your car, such as what model year and fuel type it is. This may have a bearing on the answer.
Many units in these cars are now controlled by CANBUS messages and won't appear to be turned on, even if powered, until the correct message is received.
 

NJS5

Senior Member
Joined
Jul 12, 2020
Messages
413
Reaction score
606
Location
Catherington, Hampshire.
Your Mercedes
2011 SL350, 2016 Discovery 4 Landmark, 1973 MG B GT V8, 1959 MGA roadster.
Welcome. It might also be sensible to complete your profile so we know where you are situated. Firstly someone local may be able to help & secondly we may be able to direct you to a good local "indy".

Has the new engine just been fitted?

NJSS
 

mioba

Senior Member
Joined
Feb 19, 2006
Messages
6,391
Reaction score
3,294
Location
Nottingham and Köln
Your Mercedes
W124/E200, W220/S320CDI, W205/C200, W251/R350CDI 4Matic
could be that some part of wiring harness has not been reconnected. if this problem is right after new engine - then back to the garage
 


ALL MBO Club members qualify for 15% discount on second hand parts.Please see MBO Members’ Area for discount codewww.dronsfields.com
Top Bottom