indicators flash fast

kelverdale

New Member
Joined
Oct 5, 2009
Messages
4
Reaction score
0
hello i recently brought my first merc e200 estate on v plate.my idicators dont work all the time,sometimes nothing at all,my hazard lights work fine.the indicators work better when i have side lights on or mains light on.when i brought the car i spotted the fault,the trader said it was the ignition switch and someone said it looks like a bad earth.i have changed bulbs i have took one bulb out at a time to eliminate any bad ones still the same.help please ?:(
 

oigle

Senior Member
Joined
Mar 15, 2005
Messages
3,473
Reaction score
920
Age
83
Location
Redcliffe, Queensland, Australia
Website
members.optusnet.com.au
Your Mercedes
2003 ML270 sold but not forgotten. 2022 Kia EV6 RWD LR
hello i recently brought my first merc e200 estate on v plate.my idicators dont work all the time,sometimes nothing at all,my hazard lights work fine.the indicators work better when i have side lights on or mains light on.when i brought the car i spotted the fault,the trader said it was the ignition switch and someone said it looks like a bad earth.i have changed bulbs i have took one bulb out at a time to eliminate any bad ones still the same.help please ?:(

Normally, fast flashing indicators are caused by using higher wattage bulbs - the flasher "can" speed is governed by the heat generated by the current flow. However, given the range of issues, I'd be more inclined to change the flasher "can" before looking elsewhere.
 

star

Forum Supporter
Authorised Forum Supporter
Joined
Oct 6, 2004
Messages
6,221
Reaction score
1,885
Location
Reading
Your Mercedes
Smart + others :)
test for overcharging, had this before.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
367
Age
89
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Yes as the above post,,make sure that the running voltage is no more than14 volts,,if OK change the flasher
 
OP
K

kelverdale

New Member
Joined
Oct 5, 2009
Messages
4
Reaction score
0
  • Thread Starter
  • Thread starter
  • #5
does anybody know the location of the flasher and what colour it is ? ive tried to locate it but it doesnt click or make a sound and i dont have an owners manual the ones i have found are 3 yellow and 1 black relays
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
367
Age
89
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
See what I can find for this
 

Alex Crow

Senior Member
Joined
Jul 9, 2009
Messages
10,677
Reaction score
47
Location
Super Suffolk
Your Mercedes
W169, W124, w202, W203, KTM 250 EXC, VW T25 camper and a Polo in a pear tree
kelverdale, you are getting good advice here, take note. do you have a multimeter? do you know what one is? if yes to one of the above, check the voltage at the battery when the engine is running!

question, are the indicators ok when the ignition is on but the engine not running?
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
367
Age
89
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Just where is this flasher,,I now know that it goes through the EIS into the front SAM but where is the module,,I am now looking at the SAM N10
 

Alex Crow

Senior Member
Joined
Jul 9, 2009
Messages
10,677
Reaction score
47
Location
Super Suffolk
Your Mercedes
W169, W124, w202, W203, KTM 250 EXC, VW T25 camper and a Polo in a pear tree
early 210s had a ccm like the 170s, but i think this one will be the N10 module. there is probably no timing relay like the olden days ;), but possibly a slave relay on top of the sam?
 
OP
K

kelverdale

New Member
Joined
Oct 5, 2009
Messages
4
Reaction score
0
  • Thread Starter
  • Thread starter
  • #10
yeah they still play up when the ignition is on and engine isnt runnin i havent checked the voltage yet but i will do and post back
 

oigle

Senior Member
Joined
Mar 15, 2005
Messages
3,473
Reaction score
920
Age
83
Location
Redcliffe, Queensland, Australia
Website
members.optusnet.com.au
Your Mercedes
2003 ML270 sold but not forgotten. 2022 Kia EV6 RWD LR
yeah they still play up when the ignition is on and engine isnt runnin i havent checked the voltage yet but i will do and post back

No point - without the alternator running, voltage cannot be excessive. Go for the flasher unit.
 

Alex Crow

Senior Member
Joined
Jul 9, 2009
Messages
10,677
Reaction score
47
Location
Super Suffolk
Your Mercedes
W169, W124, w202, W203, KTM 250 EXC, VW T25 camper and a Polo in a pear tree
that is a very expensive part on this car!!
 

Alex Crow

Senior Member
Joined
Jul 9, 2009
Messages
10,677
Reaction score
47
Location
Super Suffolk
Your Mercedes
W169, W124, w202, W203, KTM 250 EXC, VW T25 camper and a Polo in a pear tree
of course you could! but why would it flash fast malcolm? on this generation car there will be an oscilating (?)circuit of some description that generates a frequency regardless of output current. something basic would do it, but as you know, this level of circuitry is not my bag. enlighten us please...

fwiw i have never seen a w210 or anything else that age or newer that would flash fast, even with half the bulbs removed. some cars flash the dash green arrows fast if a bulb is out (w202), but when you have a look at the exterior signals they are at normal speed. i am assuming the o/p is not this shrt sighted so had not mentioned it before now. unless this is a w123 200t on the OLD v-reg!!!
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
367
Age
89
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
true the bulbs are on a monitoring circuit as well. I have some info on the 170 and will try and take a look later in the day
 
OP
K

kelverdale

New Member
Joined
Oct 5, 2009
Messages
4
Reaction score
0
  • Thread Starter
  • Thread starter
  • #16
thanks guys but i still cant find this flasher unit i even asked mercedes and they cant find one listed ive noticed the indicators work betta when the lights are on and also when i press the brake pedal
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
367
Age
89
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
It is all part of the N10 SAM module as far as I can see
 

geezer255

Senior Member
Joined
Oct 15, 2009
Messages
171
Reaction score
0
Location
ESSEX!!
Your Mercedes
Sprinter 311cdi - Shogun Sport
You say you have replaced the bulbs??, did you replace them with the same bulbs as you took out or with the bulbs that are listed for that model??.... just an idea......
 
Top Bottom