indicators flash too fast.

stickandrudder

Senior Member
Joined
Nov 14, 2008
Messages
275
Reaction score
0
Location
darn sarf
Your Mercedes
lots
I've got one of those mystery jobs that is proving a bit difficult to solve!
The indicators flash to fast, both left & right. Hazard flash speed is OK.
year 2000 210 chassis.
things tried so far:
All bulbs & holders swapped
N10 (front sam) renewed
PSE unit swapped
Alarm siren renewed.
Mirrors swapped.
Indicator switch renewed.
Resistances across wires at N10 checked: all OK

Straws I might clutch at:
Door SAM. I tried disconnecting the repeater lamps on another car and it does not introduce this fault so am incliined to dismiss door SAM.

EIS. The supply for the front SAM comes via the EIS, but since the flashers are obviously working I'm disinclined to suspect this.

There is a towbar fitted but we've disconnect the wiring to no avail.

I'm getting desperate and was hoping someone here might have had similar issues?

Thanks in advance
 

Alex Crow

Senior Member
Joined
Jul 9, 2009
Messages
10,677
Reaction score
40
Location
Super Suffolk
Your Mercedes
W169, W124, w202, W203, KTM 250 EXC, VW T25 camper and a Polo in a pear tree
hello s+r, have we already been involved in this one? i know it came up on the forum before, perhaps it was this one.

does the car have a mercedes towbar fitted? if so, check the microswitch just inside the socket, it may be stuck which could cause this problem.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
We have had 2 post on this in the last few weeks,,I am still at a loss to find much info on it
 
OP
S

stickandrudder

Senior Member
Joined
Nov 14, 2008
Messages
275
Reaction score
0
Location
darn sarf
Your Mercedes
lots
  • Thread Starter
  • Thread starter
  • #4
The micro switch is a good suggestion. I'll check it tomorrow thanks.
 

speedybiker

Senior Member
Joined
Apr 22, 2007
Messages
75
Reaction score
0
Location
Scotland
Your Mercedes
none
Have you maybe got a bad earth at the indicators?

I would try earthing with a lenght of cable to see if thats whats causing it

Alex.
 

Alex Crow

Senior Member
Joined
Jul 9, 2009
Messages
10,677
Reaction score
40
Location
Super Suffolk
Your Mercedes
W169, W124, w202, W203, KTM 250 EXC, VW T25 camper and a Polo in a pear tree
It's not the microswitch.......:(

did you find it then? under the hinged cover, placed to be contacted with a plug fitted. this would only be on the mercedes original equipment tow bar, and is wired into the pse unit. how can you be sure the microswitch is ok?
 
OP
S

stickandrudder

Senior Member
Joined
Nov 14, 2008
Messages
275
Reaction score
0
Location
darn sarf
Your Mercedes
lots
  • Thread Starter
  • Thread starter
  • #8
We removed the wiring for the tow bar!
We've also tried running a substitute earth cable straight to the battery from the headlamps but since the resistances in the circuit from the front SAM to the bulbs are OK I was not surprised when this didn't change anything.
I've been doing this stuff for 30 years and it's not often I'm beaten!
 

Alex Crow

Senior Member
Joined
Jul 9, 2009
Messages
10,677
Reaction score
40
Location
Super Suffolk
Your Mercedes
W169, W124, w202, W203, KTM 250 EXC, VW T25 camper and a Polo in a pear tree
removed the towbar wiring? this will only work if the microswitch is usually in the open position, if it makes a circuit when not pressed, and goes open circuit when pressed then you have proved nothing. the reason i press this point is that i have known this fault only once on a modern car (a 1999 w202), and it was caused by this very microswitch. the switch is wired to the pse unit which cans the "towbar lights in use" message to the front sam. i suggest you disconnect the pse unit (under the rear seat next to the battery) and try it again. all this assumes that you do have the MB towbar fitted. another possibility is a faulty pse unit. as the flash speed signal is generated by the front sam you have ruled that out, also the flash speed should be independent of the current load, ie if half the bulbs were blown the speed should be the same.
 
OP
S

stickandrudder

Senior Member
Joined
Nov 14, 2008
Messages
275
Reaction score
0
Location
darn sarf
Your Mercedes
lots
  • Thread Starter
  • Thread starter
  • #10
Thanks for your continued input.
I've tried both swapping and disconnecting the pse unit but will take another look at the tow bar micro-switch in the morning.
(you can tell that I'm really bugged by this because I'm here at 11.45pm!)
I'll also see if I can find the wiring diagram for the towbar on WIS, unless someone can give me the relevant doc number...........:eek:
 

DMRobinson

Member
Joined
Aug 23, 2006
Messages
21
Reaction score
0
Flasher relay? Dont know anything about the specific model, just a thought
 
OP
S

stickandrudder

Senior Member
Joined
Nov 14, 2008
Messages
275
Reaction score
0
Location
darn sarf
Your Mercedes
lots
  • Thread Starter
  • Thread starter
  • #12
With respect I suspect that you haven't read the rest of the thread!
Thanks for your thoughts anyway.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Thanks for your continued input.
I've tried both swapping and disconnecting the pse unit but will take another look at the tow bar micro-switch in the morning.
(you can tell that I'm really bugged by this because I'm here at 11.45pm!)
I'll also see if I can find the wiring diagram for the towbar on WIS, unless someone can give me the relevant doc number...........:eek:

AN31.19p-8080-03FFB
 
OP
S

stickandrudder

Senior Member
Joined
Nov 14, 2008
Messages
275
Reaction score
0
Location
darn sarf
Your Mercedes
lots
  • Thread Starter
  • Thread starter
  • #15
Mr Patient you have managed to crack it!!
It was indeed the micro switch and thanks to TV for the reference to the document.
I'm a bit long in the tooth and it always takes me ages to find anything on WIS.
Well done to both of you!!:D
 

Alex Crow

Senior Member
Joined
Jul 9, 2009
Messages
10,677
Reaction score
40
Location
Super Suffolk
Your Mercedes
W169, W124, w202, W203, KTM 250 EXC, VW T25 camper and a Polo in a pear tree
happy days, i am glad i insisted on it! so sorry that you got there the long way round, but all is well that ends well.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
happy days, i am glad i insisted on it! so sorry that you got there the long way round, but all is well that ends well.

And thank you Alex I would have never worked that one out.
 

Alex Crow

Senior Member
Joined
Jul 9, 2009
Messages
10,677
Reaction score
40
Location
Super Suffolk
Your Mercedes
W169, W124, w202, W203, KTM 250 EXC, VW T25 camper and a Polo in a pear tree
yes, it is one that you just have to know :D.
 
OP
S

stickandrudder

Senior Member
Joined
Nov 14, 2008
Messages
275
Reaction score
0
Location
darn sarf
Your Mercedes
lots
  • Thread Starter
  • Thread starter
  • #19
The irritatng thing is that I have a £100,000 per year wage bill and I still had to do it myself, even after passng on the initial tip.:mad:
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
The irritatng thing is that I have a £100,000 per year wage bill and I still had to do it myself, even after passng on the initial tip.:mad:

Never trust anyone,, I am terrible in this respect, that is why I could never employ anyone and stayed working on my own
 


Over 100 branches Nationwide, More than 114,000 Parts in Stock, The UKs Largest, and Fastest Growing Parts Supplier,please see MBO Members’ Area for discount codeEuro Car Parts Ltd
Top Bottom