1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Left Hand Licence Plate Lamp Failure

Discussion in 'Electrics, Vacuum, Ignition and ECU' started by JCP, Dec 14, 2012.

  1. JCP

    JCP Senior Member

    Messages:
    66
    Likes Received:
    2
    Joined:
    Nov 17, 2012
    Location:
    Doncaster
    Your Mercedes:
    2017 S350 L AMG Line
    Hi,

    I have a 2007 E320 CDI Estate (W211) and on Monday I had the above message displayed. I checked the lamps and replaced both number plate lamp bulbs as one had failed and the other was blackened. The new bulbs were 12V 5W.

    Today I've had the same message showing on the display although both lamps are working.

    Does anyone have any suggestions on whether I need to wipe what could be an old message (and if so, how is that achieved)? Could it be a bulb (or two) of the wrong spec?
     
  2. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    310
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    If the contacts are clean it must be the bulbs out of spec, there is no reset for this
     
  3. OP
    JCP

    JCP Senior Member

    Messages:
    66
    Likes Received:
    2
    Joined:
    Nov 17, 2012
    Location:
    Doncaster
    Your Mercedes:
    2017 S350 L AMG Line
    Many thanks for this - I'll check this in the morning. Much appreciated.
     
  4. EmilysDad

    EmilysDad Senior Member

    Messages:
    9,240
    Likes Received:
    2,768
    Joined:
    May 8, 2012
    Location:
    Bury Lancs
    Your Mercedes:
    ML350
    and fit decent make lamps ..... not cheapo cr4ppy ones
     
  5. BAZZER1

    BAZZER1 Senior Member

    Messages:
    1,542
    Likes Received:
    7
    Joined:
    Jul 9, 2011
    Location:
    FERNDOWN DORSET
    Your Mercedes:
    E320cdi AVANTGARDE SELECT
    Recently changed mine for Osram, cleaned all contacts before refitting, no problems
    BAZZER1
     
  6. Azkuma

    Azkuma Senior Member

    Messages:
    113
    Likes Received:
    3
    Joined:
    Mar 13, 2013
    Location:
    SE London
    Your Mercedes:
    SL500
    Well I didn't expect to be looking for this thread but yep I have the same warning on the dash on my SL (that sounds odd seeing as I only drove it home yesterday).

    What bulbs are recommended (Bosch or other good quality brand) and does the warning go out automatically or do I need to type in a secret code into the COMMAND unit :p?
     
  7. davidsw

    davidsw Senior Member

    Messages:
    386
    Likes Received:
    0
    Joined:
    May 24, 2011
    Location:
    cornwall
    Your Mercedes:
    Jaguar XKR ,Jaguar S-Type, Porsche Boxster S
    If correct bulbs are fitted warning will clear itself
     
  8. Wirral_guy

    Wirral_guy Active Senior Members

    Messages:
    998
    Likes Received:
    0
    Joined:
    Jul 12, 2009
    Location:
    Ness, nr Chester
    Your Mercedes:
    2004 CLK270cdi Avantgarde
    Just to add - depsite both my number plate light bulbs being changed for standard MB ones, every now and again I get the message 'left side number plate lamp faulty' (or similar). It tends to come and go and the bulb is always OK. It might be fine for 6 months and then I will have 2 weeks of intermittent messages.

    I have just put it down to a foible of the car.

    Dave
     
  9. davidsw

    davidsw Senior Member

    Messages:
    386
    Likes Received:
    0
    Joined:
    May 24, 2011
    Location:
    cornwall
    Your Mercedes:
    Jaguar XKR ,Jaguar S-Type, Porsche Boxster S
    My CLK had one number plate bulb flashing on and off every 2 seconds.
    Needed new rear sam unit £300 .!
     
  10. Azkuma

    Azkuma Senior Member

    Messages:
    113
    Likes Received:
    3
    Joined:
    Mar 13, 2013
    Location:
    SE London
    Your Mercedes:
    SL500
    :shock:

    Was this diagnosed with STAR unit at a main dealer or indy specialist?
     
  11. Azkuma

    Azkuma Senior Member

    Messages:
    113
    Likes Received:
    3
    Joined:
    Mar 13, 2013
    Location:
    SE London
    Your Mercedes:
    SL500
    What are the correct bulbs?
     
  12. Azkuma

    Azkuma Senior Member

    Messages:
    113
    Likes Received:
    3
    Joined:
    Mar 13, 2013
    Location:
    SE London
    Your Mercedes:
    SL500
    So I had my rear left bulb changed last Friday and the malfunction warning went out on the display, but just on my way home this evening and the warning message has reappeared just as I was nearing home.

    Parked up and went to see if the bulb was blown but it's not but the message is still there. Any suggestions as to what the cause could be and how to get it sorted?

    Is it a bad contacts or something more serious (I'll be on the phone in the morning), so what can I check?
     
  13. davidsw

    davidsw Senior Member

    Messages:
    386
    Likes Received:
    0
    Joined:
    May 24, 2011
    Location:
    cornwall
    Your Mercedes:
    Jaguar XKR ,Jaguar S-Type, Porsche Boxster S
    Diagnosed by indy on star
     
  14. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    310
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    When cars get to a certain age, the contacts for lamp fittings can deteriorate.

    You replace a lamp and it will never sit in the same place as the one that was taken out, By using a tin of non drying switch cleaner this will restore a good contact and turn off the warning.

    Bulbs in cars sit in a hostile environment and the contacts are just flash nickel plated so not good to use any abrasive on them
     
  15. Azkuma

    Azkuma Senior Member

    Messages:
    113
    Likes Received:
    3
    Joined:
    Mar 13, 2013
    Location:
    SE London
    Your Mercedes:
    SL500
    Before setting off this morning I lifted the boot to check again that the bulb was ok and it was. Closed the boot and prepared to set off and the warning message has gone out.

    So, I'm assuming that there is a 'contact' problem which opening and closing the boot has resolved but I will definitely use some non drying switch cleaner on the contacts as a precaution.

    I guess I have first week jitters and so the slightest thing will give me goosebumps. :p
     
  16. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    310
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    Just spray the cleaner on the contacts and rotate the festoon lamps and it could be fine, if it was a broken wire in the boot hinge they would both go off
     

Share This Page