Loping at slow speeds - E500

pmay805

Senior Member
Joined
Jul 21, 2009
Messages
120
Reaction score
0
Location
Raleigh, NC, USA
Your Mercedes
E500 2003 / Acura RL 2003
I have an E500 with 97k miles. It had the plugs replaced at about 85k. But sometimes when I'm driving through the parking lot rather slowly it will lope, ie, jerky motions, speed then slow. I also notice that at stop lights it sometimes doesn't seem to run smoothly as I notice the RPM's seem to move up and down (it's around 600 or so). I guess there are probably a dozen or so things that could be causing this. Any suggestions?

thanks
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
This is a hard one MAF possibly
 
OP
P

pmay805

Senior Member
Joined
Jul 21, 2009
Messages
120
Reaction score
0
Location
Raleigh, NC, USA
Your Mercedes
E500 2003 / Acura RL 2003
  • Thread Starter
  • Thread starter
  • #4
e500 2003...the loping doesn't happen very often...it's sporadic. Could it have to do with the transmission changing gears?
 
OP
P

pmay805

Senior Member
Joined
Jul 21, 2009
Messages
120
Reaction score
0
Location
Raleigh, NC, USA
Your Mercedes
E500 2003 / Acura RL 2003
  • Thread Starter
  • Thread starter
  • #5
Thanks Malcolm, but what is MAF?
 

Miffy

Senior Member
Joined
Sep 6, 2008
Messages
7,356
Reaction score
4
Location
Bromley, London
Your Mercedes
CLK 320 CAB Elegance C208
or an Air Leak, sounds a bit like its hunting
 


A truly one stop site for Mercedes owners. Very experienced – friendly – down to earth – cost effective repairs offering either genuine or same quality parts so that you do not compromise your Mercedes heritage or reliability. Tel: 01406 422457fleetroadgarage.co.uk
Top Bottom