MAF - (or not)?

sailorjim

Senior Member
Joined
Jan 22, 2009
Messages
142
Reaction score
10
Location
West Midlands
Your Mercedes
MB C200 EXECUTIVE ESTATE 2018
C180 11 years old with 40k miles, recent MOT ok but recently has started hunting (thrum - thrum at one thrum per second) when started between hot and cold. Hunts between 1100 and 1500 rpm when the fault shows. First cold start of the day, however, not a problem, it starts and runs smoothly and after a few seconds (or a blip on the throttle) it settles down and runs beautifully, in fact it runs better than ever these days apart from this one thing.

Today, when I got back home, I tried starting it with the MAF disconnected, again with it re-connected, and twice more. Guess what - connected I got the thrum thrum, disconnected, started perfectly. Does this mean the MAF is at fault or is this just a red herring.

As I say, it runs very well apart from this but it is a bit embarrassing moving off in kangaroo fashion.
 

c15htn

Senior Member
Joined
Jan 19, 2013
Messages
620
Reaction score
0
Location
Milton Keynes
Your Mercedes
'00 A208 CLK320 Convertible.
I'd say yes, it's faulty...... maybe not faulty, but getting a bit out of tolerance so making the car hunt.

Id probably live with it until it became a problem - as if it gets worse, you can always unplug it whilst you sort out a new one :lol:
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
341
Age
87
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Cleaning seldom works on any petrol engine. try ECP,, not Ebay
 
OP
S

sailorjim

Senior Member
Joined
Jan 22, 2009
Messages
142
Reaction score
10
Location
West Midlands
Your Mercedes
MB C200 EXECUTIVE ESTATE 2018
  • Thread Starter
  • Thread starter
  • #5
Thanks for the advice, folks, I am still puzzled as to why it starts perfectly at the first start of the day.

Is it detrimental to run it with the MAF unplugged if it get too bad?
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
341
Age
87
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Thanks for the advice, folks, I am still puzzled as to why it starts perfectly at the first start of the day.

Is it detrimental to run it with the MAF unplugged if it get too bad?

On the first start of the day fuel enrichment is used and this over rides the MAF and the MAF is not in the starting circuit
 

Alex Crow

Senior Member
Joined
Jul 9, 2009
Messages
10,677
Reaction score
40
Location
Super Suffolk
Your Mercedes
W169, W124, w202, W203, KTM 250 EXC, VW T25 camper and a Polo in a pear tree
I do no think we can conclude the MAF sensor at fault.

What engine is this - M111 or M271?
If M271, suspect the commonly split breather pipe under the air filter housing.
 
OP
S

sailorjim

Senior Member
Joined
Jan 22, 2009
Messages
142
Reaction score
10
Location
West Midlands
Your Mercedes
MB C200 EXECUTIVE ESTATE 2018
  • Thread Starter
  • Thread starter
  • #8
No, Alex, this is one of the last of the M111 engines, said to be almost bomb-proof, I believe.
 

Pathfinder

Senior Member
Joined
Dec 21, 2011
Messages
814
Reaction score
18
Age
61
Location
Gourock
Your Mercedes
CLC 220 CDi Sport Diesel Year 2008
You can spray it with electrical contact cleaner to clean it. It fixed mine and works fine. Original MAF with over 150k miles.
 
OP
S

sailorjim

Senior Member
Joined
Jan 22, 2009
Messages
142
Reaction score
10
Location
West Midlands
Your Mercedes
MB C200 EXECUTIVE ESTATE 2018
  • Thread Starter
  • Thread starter
  • #10
For the last few days it's been hunting at first start even after sitting all night, and now takes about 20 to 30 seconds to settle down, or will settle down after a hefty blip on the throttle.

I did clean it with the stuff from Halfords - easy 10 minute job plus wait for an hour to dry. Quite right, those who have said so, didn't make a blind bit of difference.

At least I have turned the engine management light off with my cheap Chinese scanner, but I can't make any sense of the gobbledegook that somes out of said scanner.

I think an expensive visit to a workshop with Star is on the cards - or maybe get rid.


.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
341
Age
87
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
For the last few days it's been hunting at first start even after sitting all night, and now takes about 20 to 30 seconds to settle down, or will settle down after a hefty blip on the throttle.

I did clean it with the stuff from Halfords - easy 10 minute job plus wait for an hour to dry. Quite right, those who have said so, didn't make a blind bit of difference.

At least I have turned the engine management light off with my cheap Chinese scanner, but I can't make any sense of the gobbledegook that somes out of said scanner.

I think an expensive visit to a workshop with Star is on the cards - or maybe get rid.


.

Why not unplug the MAF and see how it goes
 

c15htn

Senior Member
Joined
Jan 19, 2013
Messages
620
Reaction score
0
Location
Milton Keynes
Your Mercedes
'00 A208 CLK320 Convertible.
So, you say with the maf connected it runs roughly, without it out runs fine. Seems a bit extreme to get rid!
Put a maf on it, and for the sake of £150 you're sorted..... our you know to get rid lol!

We can all second guess it into the scrap yard for you..... either get it on star, or get a maf first and go from there.

It can't be that major or it would run badly with our without the meter connected.
 
OP
S

sailorjim

Senior Member
Joined
Jan 22, 2009
Messages
142
Reaction score
10
Location
West Midlands
Your Mercedes
MB C200 EXECUTIVE ESTATE 2018
  • Thread Starter
  • Thread starter
  • #13
Well, whaddya know? With the return of the warm weather this problem came back so I searched further on the web and found a couple of people who had had similar trouble and cured it by - cleaning the throttle body! There are a couple of U-tube videos out there. So I took off the air box (5 minutes) and found a load of black crud in the vicinity of the butterfly valve. Pushed the valve down against the spring and cleaned out where valve impinges with a rag soaked in cleaner and wrapped round a wide-blade screwdriver, and re-assembled (another 5 minutes).

Job done, so simple and, as someone remarked, there is nothing on the service schedule about the cleaning. Hope this can help someone else.
 
OP
S

sailorjim

Senior Member
Joined
Jan 22, 2009
Messages
142
Reaction score
10
Location
West Midlands
Your Mercedes
MB C200 EXECUTIVE ESTATE 2018
  • Thread Starter
  • Thread starter
  • #14
Even more good news! Just passed the MOT today. For the last couple of years the print-out of the emissions has shown the total HC at around 150 - dangerously near the failure rate of 200. Today, back down to 20, where it should be, and the CO has dropped by about two thirds.

Oh, share in my joy.
 

Davelincs

Senior Member
Joined
May 18, 2013
Messages
131
Reaction score
1
Location
Lincoln
Your Mercedes
E220, 2014, Audi TTRS plus
An easy fix in the end then Jim, it's worth knowing for future reference
 


GAD was founded in 2009 where we developed bespoke ECU Remapping software for motorsport clients, moving forward, we have extended to road vehicles for both performance and economy,
contact GAD Tuninghttp://www.GADTuning.co.ukto discuss your requirements.
Top Bottom