merc sprinter non starter

john924

New Member
Joined
Jul 20, 2009
Messages
7
Reaction score
0
Location
newcastle upon tyne
Your Mercedes
citroen xsara picasso/merc sprinter 208 cdi
hello every1 im new to the site and looking for help
i own a 208 cdi sprinter 2002 it started with the ecu light comin on but when i turned it of and back on it would go out then it started cutting out while drving its now been in and out of the garage for the past 2 months everey time its been on the fault diognostics it comes back with no faults but still will not start HELP ME PLEASE ive spent a fortune it turns but will not fire
 
OP
J

john924

New Member
Joined
Jul 20, 2009
Messages
7
Reaction score
0
Location
newcastle upon tyne
Your Mercedes
citroen xsara picasso/merc sprinter 208 cdi
  • Thread Starter
  • Thread starter
  • #2
merc sprinter non starter update

its been on the comp again now it shows up an injector is of then when you reset it its a different injector the mechanic put new ones on and it was still jumping between injectors and the edc light is still on come some1 must no something
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
I do not know much about sprinters is this the one with the 611 engine
 

Cnics

Senior Member
Joined
Jan 3, 2007
Messages
292
Reaction score
0
Age
37
Location
Worksop - UK
Website
www.cnics.co.uk
This is a 2.2cdi engine Malcom.


Mines in a state at the moment, if you think 2 months is bad, try 7. Mine developed an overfuelling fault when cold in December, it's been in to an indi and to MB and stayed between the 2 and various other people since. It had had a set of brand new injectors about 5000 miles before this occurred and had run perfectly. Since then it's had a complete set of sensors on the front on the fuel and turbo and air side of things, nothing has cured it. They've tested the pump, tested the injectors, all is well with those, the ECU is fine also. Nobody can get to the bottom of it, i've been vanless (well that van anyway) for 7 months and even MB can't crack it.


Your fault on the other hand would to me sound like an injector problem. Van cutting out, EDC light on, this is what happened to me when i needed a set of injectors. I never had starting trouble however. However if you've tested that, i don't really know what to suggest. (It does occasionally turn over a few extra times now when trying to start)
 
OP
J

john924

New Member
Joined
Jul 20, 2009
Messages
7
Reaction score
0
Location
newcastle upon tyne
Your Mercedes
citroen xsara picasso/merc sprinter 208 cdi
  • Thread Starter
  • Thread starter
  • #5
mb have found the problem wiring harness had a fault 4 wires fused together any more info ill let you no
 
OP
J

john924

New Member
Joined
Jul 20, 2009
Messages
7
Reaction score
0
Location
newcastle upon tyne
Your Mercedes
citroen xsara picasso/merc sprinter 208 cdi
  • Thread Starter
  • Thread starter
  • #6
non starter sorted

it all has to to with the 2 injection wires comin from the back of the managment system 1 black splits of into 2 the other blue splits of in 2 its nown as a open circuit these 2 wires goin in to box were broke so there you have it any body want more info drop me a line
 

dgesl

New Registration
Joined
Apr 28, 2010
Messages
1
Reaction score
0
Hi john

Got very similar problem . Could you please give me further detail regarding the wires ? When you say these wires where broke could you see this (was it a visable brake) or was it possibly a internal (not visable ) problem
 

You lost your key ? Or maybe you need a spare! Your vehicle imobilliser does not respond anymore? WE CAN FIX THEM ALL !! Mobile ! Save Time and Increase Profits With us !
Top Bottom