Mercedes 300D ABS fault

Wellbrook

New Member
Joined
Mar 14, 2006
Messages
9
Reaction score
0
I have a problem with the ABS warning light not going out on engine startup. It does go out sometimes after engine run awhile. Whilst the ABS warning light is on the tachometer does not work. When light goes out Tacho works OK. When light is on engine runs a little uneven, when off engine runs smoothly. Does anyone know what the likely problem to be and is there a cheap solution? Thanks
Alan B
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
This should be a faulty OVP , its the one with the fuse on top
 

wireman

Senior Member
Joined
Sep 20, 2005
Messages
2,632
Reaction score
3
Location
lancashire
Your Mercedes
nice 201 2.5D 1993 & very nice 129 SL500 1994
I'll go with malcolm again on this one, the OVP provides 12v power to ABS and tickover control.

Dig around the forum for some previous posts about this problem, the relay in some cases can be repaired and you will find my description of whats often wrong and how I have repaired them.

The OVP is under the black plastic flap behind the battery in fromt of the ABS controller and beneath another black cover that is intended to keep the elements out.
The cover and relay simply clip in place.
 
OP
W

Wellbrook

New Member
Joined
Mar 14, 2006
Messages
9
Reaction score
0
  • Thread Starter
  • Thread starter
  • #4
ABS light

Thanks for info. Have checked fuse and wiring seams OK. Will try and get a replacement. Keep you informed
Wellbrook
 

teddycatkin

Senior Member
Joined
Mar 7, 2008
Messages
2,093
Reaction score
5
Location
cheshire cheese country
Your Mercedes
W107-SL W124-220te W123-230e W201 2.0
As with others --it looks like fauty OVP --mine was "£60 inc vat Sir " from my stealer.
 

xitrum_dalat

Member
Joined
Dec 16, 2008
Messages
20
Reaction score
0
this ovp always has a small crack

between the plug leg and circuit

i cannot remember which plug number.

but if you try to find you will see.

then , just weld it.
 
OP
W

Wellbrook

New Member
Joined
Mar 14, 2006
Messages
9
Reaction score
0
  • Thread Starter
  • Thread starter
  • #7
Wellbrook
New OVP relay purchased from Partsforemercedes-benz.com. Not too expensive,excellent service and when fitted (5 mins) problem resolved. Thanks for good advice, saved a fortune.
 

You lost your key ? Or maybe you need a spare! Your vehicle imobilliser does not respond anymore? WE CAN FIX THEM ALL !! Mobile ! Save Time and Increase Profits With us !
Top Bottom