Ml 270 cdi

Thomas Paterson

New Member
Joined
Dec 23, 2017
Messages
5
Reaction score
1
Your Mercedes
Ml 270cdi
Hi after some advice my 2002 ml 270 cdi windows and mirrors work intermittently get in it to go to work no windows or mirrors after about 10 minutes driving they all start working lately it has taken longer for them to start working anything up to 30 minutes I’ve changed the relay but just the same I noticed yesterday that when they don’t work the rear aircon button is flashing but when they start working the aircon stops flashing any advice greatly appreciated thanks
 

Srdl

Senior Member
Joined
Oct 8, 2015
Messages
7,190
Reaction score
6,030
Location
Hampshire
Your Mercedes
GLC43 AMG 2018 (X253)
Hi after some advice my 2002 ml 270 cdi windows and mirrors work intermittently get in it to go to work no windows or mirrors after about 10 minutes driving they all start working lately it has taken longer for them to start working anything up to 30 minutes I’ve changed the relay but just the same I noticed yesterday that when they don’t work the rear aircon button is flashing but when they start working the aircon stops flashing any advice greatly appreciated thanks
Just a pure guess but I wonder whether this is battery related. Mercedes do weird things if the battery voltage is low which could be why things wake up once it’s been running for a while. Not sure of the significance of the AirCon light though!
 

mioba

Senior Member
Joined
Feb 19, 2006
Messages
7,971
Reaction score
4,720
Location
Nottingham and Köln
Your Mercedes
W124/E200, W220/S320CDI, W205/C200, W251/R350CDI 4Matic
If the car fires up and holds charge rule the battery out.
 
OP
T

Thomas Paterson

New Member
Joined
Dec 23, 2017
Messages
5
Reaction score
1
Your Mercedes
Ml 270cdi
  • Thread Starter
  • Thread starter
  • #5
The car starts fine and holds charge it’s relatively new Bosch s5 I’m inclined to think it’s something to do with the rear heater as the controls flicker red even when the car is turned off any thoughts many thanks
 

Blobcat

Moderator
Joined
Feb 8, 2006
Messages
39,135
Reaction score
28,041
Location
Grange Moor
Your Mercedes
R171 SLK280, Smart R451, Land Rover 110 County SW, 997 C2S, R1250 GSA TE 40th, CBR600FP
I’d be suspecting water in the electrics somewhere
 
OP
T

Thomas Paterson

New Member
Joined
Dec 23, 2017
Messages
5
Reaction score
1
Your Mercedes
Ml 270cdi
  • Thread Starter
  • Thread starter
  • #8
Been looking for which fuse that is any idea thanks
 

mattkh

Senior Member
Joined
Aug 2, 2006
Messages
3,171
Reaction score
354
Location
England
Your Mercedes
A160 W168 1999 1.6
Try fuse 36. It is shown as for rear windscreen heater.
 
OP
T

Thomas Paterson

New Member
Joined
Dec 23, 2017
Messages
5
Reaction score
1
Your Mercedes
Ml 270cdi
  • Thread Starter
  • Thread starter
  • #11
Think I’ve managed to fix it disconnected the battery and everything back to normal must of reset its self thanks for all your input
 
Top Bottom