ML270cdi esp bas light on

Merc hater

New Registration
Joined
Jul 14, 2009
Messages
1
Reaction score
0
Can anyone help with a major headache on this mercedes ML270 2002 reg.
Have carried out numerous diagnostic checks and have had the vehicle checked by independent mercedes specialist with no joy of results.The code remain the same no matter what parts are replaced or unplugged.I have the following codes in my system C1035 steering angle sensor-n49 signal from component is faulty, C1037 rotation speed and lateral accelerator sensor-b24/ 15 fault in can communication C1040 rotation speed and lateral accelerator sensor-b24/ 15 fault in can communication.

I have replaced second hand steering angle sensor but no change was thinking of trying lateral sensor but it is now combined with yaw sensor at £300 cost. I have also checked wiring pins to and on esp unit which i believe are a common failure but these are clean. On live data i get no signal on lateral sensor or steering angle sensor, unplugging these components do not alter information on snap on solus sensor.Abs sensors show readings on roadtest and have tried manual re-set proceedures.
Can anybody help before i lose my marbles
 

stella best

Active Member
Joined
Dec 21, 2006
Messages
32
Reaction score
0
Brake light switch (same lights on my ML500 with the abs light as well) Less than a £tenna
 

turbopete

Senior Member
Joined
Feb 4, 2009
Messages
14,204
Reaction score
328
Age
46
Location
Spennymoor
Your Mercedes
2010 '60' Ford Mondeo 2.0TDCi Zetec (sorry)
as above, brake light switch. i think theyre slightly over a tenner now though. only by a quid or so! when replaced, try turning car full lock to full lock on the steering about 3 times each direction so column can re learn its position settings. i believe thats the way to reset the steering sensors!
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
I do not think that the brake lamp fault applies to the ML,, the ESP control can get corroded pins on the connector,,they can be cleaned OK
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
It applied to mine,,, thank f%%k cheepest fix ive ever had :lol:

You are right :D:D and I used to tell people to go and change it,,and I more than likely told you to
 


Over 100 branches Nationwide, More than 114,000 Parts in Stock, The UKs Largest, and Fastest Growing Parts Supplier,please see MBO Members’ Area for discount codeEuro Car Parts Ltd
Top Bottom