Multifunction display W211 E320Cdi 2003

sachkhund

Active Member
Joined
Jun 26, 2009
Messages
33
Reaction score
0
Hi, my multifunction speedometer display on my E320 Cdi 2003 seems to turn brighter when I switch the engine on.
Can not see anything on the screen as engine runs,it seems that the multifunction display is getting more voltage.

Does any one know about this problem, or what can I do to rectify.

Regards
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
If you have a dud cell on the battery,,then maybe the voltage is too low, hence the difference.

You could measure both batteries before you start the car, and they should both have 12.5 volts on them
 

xavierx

Senior Member
Joined
Sep 16, 2009
Messages
237
Reaction score
0
Your Mercedes
2004 W211 E320 CDi
Bad alternator regulator? Try measuring the battery voltage with the engine running and post your results
 
OP
S

sachkhund

Active Member
Joined
Jun 26, 2009
Messages
33
Reaction score
0
  • Thread Starter
  • Thread starter
  • #4
Hi, I have also noticed that my multifunction cluster lights do not come on at night, any ideas?
Thanks
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
When you say malfunction lights,,do you mean the tell tail lamps. With all of these things the power supply,in this case the battery does need to be known,, the difference between the standing voltage and running voltage should be no more than 1.5 to 2.0 volts, without knowing this it makes diagnosis impossible
 
OP
S

sachkhund

Active Member
Joined
Jun 26, 2009
Messages
33
Reaction score
0
  • Thread Starter
  • Thread starter
  • #6
When you say malfunction lights,,do you mean the tell tail lamps. With all of these things the power supply,in this case the battery does need to be known,, the difference between the standing voltage and running voltage should be no more than 1.5 to 2.0 volts, without knowing this it makes diagnosis impossible


The voltage at standstill is 11.91 volts, with engine running 13.70 volts
Difference of 1.79 volts.

Multifunctions lights are the small lights that make it possible for driver to see the speed, rev meter, clock, etc.

Thanks
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Thanks for the feed backI wil see if I can find something this evening. Could iit be that you have turned down the dash dimmer for the lamps at night
 
OP
S

sachkhund

Active Member
Joined
Jun 26, 2009
Messages
33
Reaction score
0
  • Thread Starter
  • Thread starter
  • #8
Thanks for the feed backI wil see if I can find something this evening. Could iit be that you have turned down the dash dimmer for the lamps at night

I have checked the dimmer knob, and the fuses.
 
OP
S

sachkhund

Active Member
Joined
Jun 26, 2009
Messages
33
Reaction score
0
  • Thread Starter
  • Thread starter
  • #9
Thank you all for your comments, however the problem has sorted it self out.
Thanks
 

Peter Best Insurance is a leading specialist in Mercedes-Benz insurance. All MBO members are eligible for exclusive rates on all our classic car policies.
Call now for our 'BEST' quote. Tel: 01376 573033
Top Bottom