1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

No heating plug light on dash is this the module away

Discussion in 'Electrics, Vacuum, Ignition and ECU' started by mercmancdi, May 14, 2019.

  1. mercmancdi

    mercmancdi Senior Member

    Messages:
    2,462
    Likes Received:
    340
    Joined:
    Dec 6, 2011
    Location:
    templepatrick - co antrim
    Your Mercedes:
    2009 E250 cdi 08 cls320 cdi ,2007 e280 cdi '2005 E 280 CDI ,VW TOUAREG ,JAGUAR S AND xTO NAME A FEW
    no light at all on my dash of 06 clk 320
    cdi for glow plugs, also noticed turns quickly a few times before staring and throws out a puff of smoke so getting fuel ok.
    Would faulty glow plug module be the fault as there’s no dash light coming on at alll
    Funny no fault showed up on icarsoft Mb scan.
     
  2. Wighty

    Wighty Senior Member

    Messages:
    6,246
    Likes Received:
    3,440
    Joined:
    Aug 4, 2016
    Location:
    Sunny Essex
    Your Mercedes:
    W211/E320cdi/2009 and CLK200k 2009
    Does the light show up at all when you turn the key to second position (when all dash lights are tested )before the engine fires ?
     
  3. OP
    mercmancdi

    mercmancdi Senior Member

    Messages:
    2,462
    Likes Received:
    340
    Joined:
    Dec 6, 2011
    Location:
    templepatrick - co antrim
    Your Mercedes:
    2009 E250 cdi 08 cls320 cdi ,2007 e280 cdi '2005 E 280 CDI ,VW TOUAREG ,JAGUAR S AND xTO NAME A FEW
    No getting no glow plug light at all
     
  4. d215yq

    d215yq Senior Member

    Messages:
    1,986
    Likes Received:
    235
    Joined:
    Mar 28, 2008
    Location:
    Barcelona
    Your Mercedes:
    1987 W124 300D 250k
    Different age car so maybe different electronics but the light suddenly disappeared on mine and at same time was a bit slower to start when cold and with a puff of smoke when lower than 10 degrees. Tested with multimeter and relay worked for all 6 pins and 5 of glowplugs were good ohms, one bad, so thought maybe the glowplug going bad messed up the light part of the circuit?

    Either way been like that for 4 years without light starting fine above 15 degrees, and good enough with a bit of accelerator even to -3 (the lowest I started it at).
     
  5. mersum1es

    mersum1es Senior Member

    Messages:
    1,688
    Likes Received:
    98
    Joined:
    Sep 25, 2010
    Location:
    Finland
    Your Mercedes:
    W219/-07/320CDI, W220/-01/320CDI, EX:W211/-04/320CDI, EX:W210/-01/270CDI
    Inline engines (OM63X series) are better starters than V engine (I believe OP has one?), and faulty pre glow system may well cause puff of smoke. Usually faulty plug is indicated my coil light staying on after start, have have got same thing happening when I left controller feed plug loosen in my OM613 by mistake. Better read the codes and test glow system before throwing money to new parts.
     
    mercmancdi likes this.
  6. Wighty

    Wighty Senior Member

    Messages:
    6,246
    Likes Received:
    3,440
    Joined:
    Aug 4, 2016
    Location:
    Sunny Essex
    Your Mercedes:
    W211/E320cdi/2009 and CLK200k 2009
    You could test the glow plugs with a resistance meter , if they check out ok then maybe the GP module ?
    I'm guessing MB Star may be able to drill down deeper for faults , if it was me though I would look at replacing the module at maybe £115 (especially when you factor in the cost of a Star session) , especially as they are a common failure .
    I take it the cars battery is ok ?
     
    mercmancdi likes this.
  7. OP
    mercmancdi

    mercmancdi Senior Member

    Messages:
    2,462
    Likes Received:
    340
    Joined:
    Dec 6, 2011
    Location:
    templepatrick - co antrim
    Your Mercedes:
    2009 E250 cdi 08 cls320 cdi ,2007 e280 cdi '2005 E 280 CDI ,VW TOUAREG ,JAGUAR S AND xTO NAME A FEW
    Yes good battery and 90% sure it’s
    heating , any fault I had with glow plug before always showed up with the light staying on , but in this case
    I am thinking module as there’s no light at all , will maybe take module off it looks simple enough and clean terminals and get part number from it while it’s off.
     
  8. OP
    mercmancdi

    mercmancdi Senior Member

    Messages:
    2,462
    Likes Received:
    340
    Joined:
    Dec 6, 2011
    Location:
    templepatrick - co antrim
    Your Mercedes:
    2009 E250 cdi 08 cls320 cdi ,2007 e280 cdi '2005 E 280 CDI ,VW TOUAREG ,JAGUAR S AND xTO NAME A FEW
    Yes om642 v6 , no light at all
     
  9. Wighty

    Wighty Senior Member

    Messages:
    6,246
    Likes Received:
    3,440
    Joined:
    Aug 4, 2016
    Location:
    Sunny Essex
    Your Mercedes:
    W211/E320cdi/2009 and CLK200k 2009
    Same engine as mine , there have been updated modules if yours is original it's well overdue .
     
    mercmancdi likes this.
  10. OP
    mercmancdi

    mercmancdi Senior Member

    Messages:
    2,462
    Likes Received:
    340
    Joined:
    Dec 6, 2011
    Location:
    templepatrick - co antrim
    Your Mercedes:
    2009 E250 cdi 08 cls320 cdi ,2007 e280 cdi '2005 E 280 CDI ,VW TOUAREG ,JAGUAR S AND xTO NAME A FEW
    I thought the icarsoft would have shown me a fault in the heating , unless I am using it wrong.
     
  11. Wighty

    Wighty Senior Member

    Messages:
    6,246
    Likes Received:
    3,440
    Joined:
    Aug 4, 2016
    Location:
    Sunny Essex
    Your Mercedes:
    W211/E320cdi/2009 and CLK200k 2009
    No idea buddy , sorry .
     
  12. brianbrian

    brianbrian Senior Member

    Messages:
    2,603
    Likes Received:
    112
    Joined:
    Sep 27, 2008
    Location:
    cockney in the West Country
    Your Mercedes:
    w124 250D, SL129-deisel
    Are you getting a reading on the glow plug relay
     
  13. OP
    mercmancdi

    mercmancdi Senior Member

    Messages:
    2,462
    Likes Received:
    340
    Joined:
    Dec 6, 2011
    Location:
    templepatrick - co antrim
    Your Mercedes:
    2009 E250 cdi 08 cls320 cdi ,2007 e280 cdi '2005 E 280 CDI ,VW TOUAREG ,JAGUAR S AND xTO NAME A FEW
    Not tried it yet ,I think I need to remove the top bracket for easier access.
     
  14. OP
    mercmancdi

    mercmancdi Senior Member

    Messages:
    2,462
    Likes Received:
    340
    Joined:
    Dec 6, 2011
    Location:
    templepatrick - co antrim
    Your Mercedes:
    2009 E250 cdi 08 cls320 cdi ,2007 e280 cdi '2005 E 280 CDI ,VW TOUAREG ,JAGUAR S AND xTO NAME A FEW
    Last v6 I had when had faulty glo plug my light stayed on after engine started.
    I run this one through icarsoft v2 but nothing showed up . Starting ok but would like it corrected .
     
  15. OP
    mercmancdi

    mercmancdi Senior Member

    Messages:
    2,462
    Likes Received:
    340
    Joined:
    Dec 6, 2011
    Location:
    templepatrick - co antrim
    Your Mercedes:
    2009 E250 cdi 08 cls320 cdi ,2007 e280 cdi '2005 E 280 CDI ,VW TOUAREG ,JAGUAR S AND xTO NAME A FEW
    is that module under the plate near front of engine. Looks like 2 plugs
     
  16. Tony Dyson

    Tony Dyson Senior Member

    Messages:
    884
    Likes Received:
    280
    Joined:
    Aug 26, 2018
    Location:
    God's Country
    Your Mercedes:
    2014 C 220 CDI W204 OM 651
    When was the last time you updated the software on your icarsoft MB2? current Diagnostics Module is software v11.10.
     
    mercmancdi likes this.
  17. V6Matty

    V6Matty Senior Member

    Messages:
    5,623
    Likes Received:
    653
    Joined:
    Aug 1, 2012
    Location:
    Newark, Notts
    Your Mercedes:
    S212/10/E350(His) W169/2005/A180 (Hers)
    Likelihood is you have a plug gone but the light not showing up at all could just be the build has gone in the cluster, would at least explain the no errors
     
    mercmancdi likes this.
  18. OP
    mercmancdi

    mercmancdi Senior Member

    Messages:
    2,462
    Likes Received:
    340
    Joined:
    Dec 6, 2011
    Location:
    templepatrick - co antrim
    Your Mercedes:
    2009 E250 cdi 08 cls320 cdi ,2007 e280 cdi '2005 E 280 CDI ,VW TOUAREG ,JAGUAR S AND xTO NAME A FEW
    Will need to check that out.
     
  19. Wighty

    Wighty Senior Member

    Messages:
    6,246
    Likes Received:
    3,440
    Joined:
    Aug 4, 2016
    Location:
    Sunny Essex
    Your Mercedes:
    W211/E320cdi/2009 and CLK200k 2009
    image.jpeg
     
    mercmancdi likes this.
  20. LostKiwi

    LostKiwi Senior Member

    Messages:
    18,039
    Likes Received:
    8,261
    Joined:
    Aug 25, 2006
    Location:
    Midlands / Charente-Maritime
    Your Mercedes:
    '93 500SL-32, '01 W210 Estate E240, 02 R230 SL500 (Malcolm Spec), 04 Smart Roadster Coupe
    Wighty likes this.

Share This Page