no power after fuel filter renewal.311 cdi

tom757xx

New Member
Joined
Jul 23, 2009
Messages
4
Reaction score
0
replaced the fuel filter and filled fuel filter with diesel, when i start the engine it wont go over 2000 revs and stalls now and again, also when i start the engine some kind of pump under the n/r side headlight starts to wind up really loud...please help:(
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
365
Age
89
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Can you see any air bubbles in the pipes,,was it OK before you started doing the filters
 
OP
T

tom757xx

New Member
Joined
Jul 23, 2009
Messages
4
Reaction score
0
  • Thread Starter
  • Thread starter
  • #3
yes it was fine

was fine till i replaced the filter, have tried the old one back on again and its still got no power. It idles fine but press the peddle and its only revving to 2 and half thousand revs,cant see any bubbles in fuel linw and that motor is making a hell of a whine
 

HUSKY

Active Member
Joined
Nov 11, 2007
Messages
27
Reaction score
0
Location
Steyning, nr Worthing
Your Mercedes
S500 1997 & C250TD 1999
was fine till i replaced the filter, have tried the old one back on again and its still got no power. It idles fine but press the peddle and its only revving to 2 and half thousand revs,cant see any bubbles in fuel linw and that motor is making a hell of a whine

Hi, did you figure out what the problem was?

Am about to change the fuel filter on my 313cdi, your post has made me a tad wary!
 


ALL MBO Club members qualify for 15% discount on second hand parts.Please see MBO Members’ Area for discount codewww.dronsfields.com
Top Bottom