1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

No screen washers

Discussion in 'Electrics, Vacuum, Ignition and ECU' started by MikeVernon, Nov 2, 2012.

  1. MikeVernon

    MikeVernon Member

    Messages:
    23
    Likes Received:
    1
    Joined:
    Apr 9, 2011
    Your Mercedes:
    slk320 2002 3.2
    My SLK 320 has no screen wash function. No power on switch actuation to washer pump in RH front wheel arch, but wipers function correctly . I do not have a circuit diagram for this car, does anyone have a link to one please?
    Is the pump relay controlled, or directly switched off the column stalk?
    Thanks.
     
  2. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    274
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    It is normally the stalk that fails on these, it is all wired via the N10 multifunction relay
     
  3. OP
    MikeVernon

    MikeVernon Member

    Messages:
    23
    Likes Received:
    1
    Joined:
    Apr 9, 2011
    Your Mercedes:
    slk320 2002 3.2
    I think the stalk switch is ok because pressing it inwards still operates the wipers which continue for around 3 passes after it is released. But power doesn't reach the pump motor.
    The feed wire to the pump motor is red/green. are you saying that this comes from the N10 relay? Do you have access to a wiring diagram so that I can trace it back to the N10?
    Many thanks.
     
  4. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    274
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    I have printed off what there is and I can send send it to you

    N5 is the pump
    N10 the multifunction relay
    S4 combination switch
     
  5. OP
    MikeVernon

    MikeVernon Member

    Messages:
    23
    Likes Received:
    1
    Joined:
    Apr 9, 2011
    Your Mercedes:
    slk320 2002 3.2
    Hi Malcolm
    That would be wonderful if you could send it to me.
    My email is mikevernon@talktalk.net.
    Many thanks.
    Mike
     
  6. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    274
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    OK you can edit out your address
     
  7. OP
    MikeVernon

    MikeVernon Member

    Messages:
    23
    Likes Received:
    1
    Joined:
    Apr 9, 2011
    Your Mercedes:
    slk320 2002 3.2
    Hi Malcolm
    Many thanks for sending the wiring diagram.
    Presumably M5/1 is the pump motor, but what are the other two components, x1 and x26/23? Am I right in thinking that x1 is a connector, probably located under the dashboard, and x26/23 is a relay? If it is a relay then where is it located?
    Regards
    Mike
     
  8. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    274
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    All X numbers are plus and sockets
     
  9. Cole@MBS

    Cole@MBS Forum Supporter Authorised Forum Supporter

    Messages:
    13,490
    Likes Received:
    497
    Joined:
    Dec 1, 2008
    Location:
    Hedge End, Southampton
    Your Mercedes:
    124 300 CE 24 Coupe, 209 240 CLK
    Just test for 12 volt at the pump, it is a common fault on the 170 to want a washer pump or two in its life!!
     
  10. OP
    MikeVernon

    MikeVernon Member

    Messages:
    23
    Likes Received:
    1
    Joined:
    Apr 9, 2011
    Your Mercedes:
    slk320 2002 3.2
    Sorry Malcolm, I don't understand what you mean. Plus and sockets?


    Cole@mbs. I don't have 12v at the pump motor, that is the problem.
     
  11. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    274
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    I will try again all of the X are connection points, they are not components.

    There is a list saying where all the X points and connections are
     
  12. OP
    MikeVernon

    MikeVernon Member

    Messages:
    23
    Likes Received:
    1
    Joined:
    Apr 9, 2011
    Your Mercedes:
    slk320 2002 3.2
    Surely x26 is a component such as a relay?

    If it is simply a connection point it means that the pump motor is wired direct to the switch on the steering column.
     
  13. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    274
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    Sorry all X points are connections and X26 is a connection point, I have just looked
     
  14. OP
    MikeVernon

    MikeVernon Member

    Messages:
    23
    Likes Received:
    1
    Joined:
    Apr 9, 2011
    Your Mercedes:
    slk320 2002 3.2
    Malcolm, that makes no sense at all. The diagram you sent me shows two alternatives for the x26/23 component, one for 1998-2001 cars and one for 2002 onwards. If it were simply a connection point why would it make such a distinction? It must be a component, and a relay seems like the obvious one.
     
  15. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    274
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    I tell you it is a connection point, and this point changed, it is not a relay,
     

Share This Page