non metallic rattle on A170cdi when idling

K

karlos2000

Guest
sound issues are hard (maybe impossible?!) to diagnose on a forum, but let me at least try to describe the sound from my workhorse baby .......

I have a 2004 A170 cdi classic auto (but actually built in March 2003).
85,000+ miles on it .....
Somewhere from the top end, on the drive belt(s) side of the engine, always from cold, and worse in extreme cold but clears totally and sounds sweet over 1000 rpm. More of a clobbering rattle, a plastic trim rattle almost. Not one of those terminal failure noises you get before an engine destroys itself, this is more of a sound you would associate with something running out of true or loose.
Took it to the MB independents, but sure enough by the time I got there the rattle had gone!!, but they said it was possibly the multi belt tensioner.

Question: does this sound likely? is it a known weak point on this plant? they quoted £237.00, they are good and I trust their judgment, I'm just trying to establish that this is a likely cause before I ask them to go ahead.

cheers

K2K
 
OP
K

karlos2000

Guest
  • Thread Starter
  • Thread starter
  • #4
aaahhh bingo then, sound like my guys are good!

thank you :p
finally had this work done in November last year, noise is still there, not as bad, but still noticeable, seems the alternator is on the way out ......

for info :eek:

cheers
 

You lost your key ? Or maybe you need a spare! Your vehicle imobilliser does not respond anymore? WE CAN FIX THEM ALL !! Mobile ! Save Time and Increase Profits With us !
Top Bottom