Odd ABS/ESP problem

benoliver

Member
Joined
Jan 20, 2007
Messages
22
Reaction score
0
Your Mercedes
1999 S210 E240, my first Merc. Rusty but I love it!!
Hello all, I have a bizarre problem with my 1999 S210 E Class and I was hoping that some of the minds on here will be able to help...

I started seeing the ABS/ESP faulty warning on occasional journeys, normally switching off the engine and restarting cleared the error, and on I would go. I changed the brake light switch just in case it was that, but the error came back again on a trip to France. I noticed that it would only happen at speed, and fully loaded, and only after about an hour of driving. When I potter around on my own going to an from work, even at motorway speeds I don't see it.

I then noticed last weekend when my wife was sitting in the back seat with the baby, I got the warning again, so I am wondering if there is a sensor or something similar on the right rear axle that may be causing the error, but only when the car is loaded????

Any advice or thoughts would be greatly appreciated!!!

Cheers
Ben
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
I would clean up the rear sensors to start with, and the rings
 

Hertfordshire Merx

Senior Member
Joined
Feb 16, 2009
Messages
353
Reaction score
0
Your Mercedes
A160
Could also look at the wiring to the rear sensor mounted in the differential. The plug is if my memory serves me right under the back seat. May have a damaged wire there or corrosion in the plug.

Hope this helps.
 
OP
B

benoliver

Member
Joined
Jan 20, 2007
Messages
22
Reaction score
0
Your Mercedes
1999 S210 E240, my first Merc. Rusty but I love it!!
  • Thread Starter
  • Thread starter
  • #4
Could also look at the wiring to the rear sensor mounted in the differential. The plug is if my memory serves me right under the back seat. May have a damaged wire there or corrosion in the plug.

Hope this helps.


Thanks for that...I live in Letchworth, so may be popping in!!! Cheers.
 
OP
B

benoliver

Member
Joined
Jan 20, 2007
Messages
22
Reaction score
0
Your Mercedes
1999 S210 E240, my first Merc. Rusty but I love it!!
  • Thread Starter
  • Thread starter
  • #5
I would clean up the rear sensors to start with, and the rings

Thanks Malcolm, is this shown on the Russian site do you know? I can't access it from work!
 

Hertfordshire Merx

Senior Member
Joined
Feb 16, 2009
Messages
353
Reaction score
0
Your Mercedes
A160
OK, well if you get stuck you're more than welcome to pop in and see us I will be very pleased to help you out...
 

Peter Best Insurance is a leading specialist in Mercedes-Benz insurance. All MBO members are eligible for exclusive rates on all our classic car policies.
Call now for our 'BEST' quote. Tel: 01376 573033
Top Bottom