R129 500SL high beam flash / fog light / bulb warning problems

MarkGolf

Senior Member
Joined
Jul 4, 2006
Messages
90
Reaction score
48
Location
S. London
Your Mercedes
R129 SL500, Porsche 997, Porsche 964, VR6, Eunos Roadster Turbo, Focus RS, Focus TDCI
Hello,

My newly purchased R129 500 is plagued with gremlins.

The bulb warning light always appears when switching the sidelights on, all bulbs are working, front side lights, rear tail lights and plate lights (if they’re included in the warning). I have changed the side and taillights for new bulbs but I still get the warning bulb appear on the dash! (Didn’t change plate bulbs)

2ns issue
My high beam flasher doesn’t work, if I pull the stalk, nothing happens yet if I push it, the high beams work. I pulled the stalk out and tested it, no issues with the switch. I’m lost on what to check next.

3rd issue
This only occurred today after poking around pulling the fuse box up and out, my drivers side fog light just won’t work, I changed the bulb but no joy. I tapped the relay box behind the fuse box and noticed it would turn off the passenger side light!!! So, I’d there a relay in here which could be faulty?

HELPPPPPP I have gremlins giving me a nightmare.

I also noticed my fuel gauge needle flick to empty and then back when activity the indicators when just on ignition!

WGATS GOING IN
 
OP
MarkGolf

MarkGolf

Senior Member
Joined
Jul 4, 2006
Messages
90
Reaction score
48
Location
S. London
Your Mercedes
R129 SL500, Porsche 997, Porsche 964, VR6, Eunos Roadster Turbo, Focus RS, Focus TDCI
  • Thread Starter
  • Thread starter
  • #2
https://flic.kr/p/24F9RSx

Am I missing a relay here?

24F9RSx
 
OP
MarkGolf

MarkGolf

Senior Member
Joined
Jul 4, 2006
Messages
90
Reaction score
48
Location
S. London
Your Mercedes
R129 SL500, Porsche 997, Porsche 964, VR6, Eunos Roadster Turbo, Focus RS, Focus TDCI
  • Thread Starter
  • Thread starter
  • #3
@LostKiwi i know you’ll have some info here! Lol
 

LostKiwi

Senior Member
Joined
Aug 25, 2006
Messages
26,455
Reaction score
15,903
Location
Midlands / Charente-Maritime
Your Mercedes
'93 500SL-32, '01 W210 Estate E240, 02 R230 SL500 (Malcolm Spec), 04 Smart Roadster Coupe
The bulb warning light always appears when switching the sidelights on, all bulbs are working, front side lights, rear tail lights and plate lights (if they’re included in the warning). I have changed the side and taillights for new bulbs but I still get the warning bulb appear on the dash! (Didn’t change plate bulbs)
Number plate lights are included in the bulb warnings.
Make sure all bulbs are in spec and not been fitted with LEDs as that will upset it.
Bulb warning (from memory) is handled by N10 relay I think (but could be wrong)

My high beam flasher doesn’t work, if I pull the stalk, nothing happens yet if I push it, the high beams work. I pulled the stalk out and tested it, no issues with the switch. I’m lost on what to check next.
Not sure on this one but again the N10 relay is responsible (subject to caveat above).

This only occurred today after poking around pulling the fuse box up and out, my drivers side fog light just won’t work, I changed the bulb but no joy. I tapped the relay box behind the fuse box and noticed it would turn off the passenger side light!!! So, I’d there a relay in here which could be faulty?
Check the earth for the fog light itself. I had the same issue and the earth connection was corroded.

I also noticed my fuel gauge needle flick to empty and then back when activity the indicators when just on ignition!
Again suggests a bad earth on the cluster. Any time one circuit affects an unrelated one always look at the earths as one is sure to be bad.
 

LostKiwi

Senior Member
Joined
Aug 25, 2006
Messages
26,455
Reaction score
15,903
Location
Midlands / Charente-Maritime
Your Mercedes
'93 500SL-32, '01 W210 Estate E240, 02 R230 SL500 (Malcolm Spec), 04 Smart Roadster Coupe
Just checked - its not the N10 - thats for Indicators, hazards and wipers. Its relay part number 1295420132 under the fusebox. That relay is responsible for all lighting functions including bulb failure warning.
 
OP
MarkGolf

MarkGolf

Senior Member
Joined
Jul 4, 2006
Messages
90
Reaction score
48
Location
S. London
Your Mercedes
R129 SL500, Porsche 997, Porsche 964, VR6, Eunos Roadster Turbo, Focus RS, Focus TDCI
  • Thread Starter
  • Thread starter
  • #6
My hero, thanks buddy!

This is my relay box, i may open it up and take a look.

40480834855_ce5f1aa4e0_z.jpg


Thanks for the tips on the earths, I must have a bad earth somewhere!! Under the fusebox was completly filled with crap, mud, leaves etc, and under my passenger seat is damp so im wondering if there is an earth joint in one of these locations that needs a clean. All of these issues must be related.
 

DREAMER NO2

Senior Member
Joined
Dec 29, 2013
Messages
3,606
Reaction score
719
Age
76
Location
Kidderminster in Worcestershire
Your Mercedes
W124 2.6E M103 1989
.The one on the right in your box is the lights module relay .Thats the one you need to pull out and check 129 542 00 32 is on the top of it ..
 
OP
MarkGolf

MarkGolf

Senior Member
Joined
Jul 4, 2006
Messages
90
Reaction score
48
Location
S. London
Your Mercedes
R129 SL500, Porsche 997, Porsche 964, VR6, Eunos Roadster Turbo, Focus RS, Focus TDCI
  • Thread Starter
  • Thread starter
  • #10
Hi Guys,

I dont thnk the dash flash is my issue although perhaps a capacitor has blown which has resulted in my clock only working when the car is off...

As for the lack of main beam flasher and bulb warning light, i pulled the module 129 542 00 32 and resoldered some dry looking joints, no joys there.. :(

Going to check the joints on the N10 relay just incase.

Otherwise, I can only think to buy another light module to see if a replacement does anything..
 


Over 100 branches Nationwide, More than 114,000 Parts in Stock, The UKs Largest, and Fastest Growing Parts Supplier,please see MBO Members’ Area for discount codeEuro Car Parts Ltd
Top Bottom