R129, Push the horn blows a fuse?

Drogo

Member
Joined
Jun 10, 2009
Messages
12
Reaction score
0
Location
Bexley
Your Mercedes
SL 500, Lexus IS200
Hi All

Little problem (I hope) with my SL. R129 1994 SL500

Today had to use the horn then found the windows, roof and indicator fuse had blown. Also warning light for no seatbelt come up on the dash.

A friend suspects a problem with one of the horns, could be in short circuit. So can somebody tell me where to the find the horns or have another idea as to what my problem my be.

Many thanks in advance.

Dave
 

Alex Crow

Senior Member
Joined
Jul 9, 2009
Messages
10,677
Reaction score
46
Location
Super Suffolk
Your Mercedes
W169, W124, w202, W203, KTM 250 EXC, VW T25 camper and a Polo in a pear tree
have you replaced the fuse yet? was it really blown? i ask because these fuses are very prone to corrosion problems on the ends, i thought that may be worth mentioning. otherwise if you are entirely sure that it is the horn blowing the fuse, better check the wiring for shorts, then disconnect the horns one at a time to pinpoint the dodgy one.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
364
Age
88
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
As Alex above,,it is worth cleaning all of the fuses first with a non drying switch cleaner before anythiing else,let us know please
 
OP
D

Drogo

Member
Joined
Jun 10, 2009
Messages
12
Reaction score
0
Location
Bexley
Your Mercedes
SL 500, Lexus IS200
  • Thread Starter
  • Thread starter
  • #4
Hi Guys

Yes, fuse was blown and when replaced all was fine until the horn was pushed.
We did notice all the fuses need cleaning so that's a little job for later today but I'm having trouble finding the horns for the disconnect test.
 

Alex Crow

Senior Member
Joined
Jul 9, 2009
Messages
10,677
Reaction score
46
Location
Super Suffolk
Your Mercedes
W169, W124, w202, W203, KTM 250 EXC, VW T25 camper and a Polo in a pear tree
are they not in front of the radiator then? if not have a look behind the panels forward of the front wheels, o/s first i would think.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
364
Age
88
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
They are just in front of the rad,, it is a live feed for the horns in the steering column
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
364
Age
88
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
I should have added that when you find the horns, pull the connectors off and press the push, if the fuse does not blow, then it will be one of the horns S/C. If the fuse blows with the horns off, then probably the horn ring contact
 
OP
D

Drogo

Member
Joined
Jun 10, 2009
Messages
12
Reaction score
0
Location
Bexley
Your Mercedes
SL 500, Lexus IS200
  • Thread Starter
  • Thread starter
  • #8
Well I've been out, cleaned all the fuses but have decided it's, Sunday, too cold, not in my garage and wifey is expecting to be taken out to dinner to go any further today.

I'm very much thinking it's down to a duff horn but still can't see where the horns are so guess I need to get under the front and take the cover off.

Thanks for the replies and I'll update when I do sort it.

Dave
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
364
Age
88
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Though mine were on the front by the rad,, the fanfare horne are mounted under the front wheel arch liners
 
OP
D

Drogo

Member
Joined
Jun 10, 2009
Messages
12
Reaction score
0
Location
Bexley
Your Mercedes
SL 500, Lexus IS200
  • Thread Starter
  • Thread starter
  • #10
Update, found and fixed.

Found the horns, both behind o/s fog light.

Removed them both, one rattles when shaken but having cleaned the terminals each was reconnected and both worked without blowing the fuse?!!!

I had cleaned all the fuses I could find so can only think it's got something to do with bad connection's? All seems OK for now so can get on with replacing the dash lights that don't work.
Thanks for all the replies.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
364
Age
88
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Pleased that it is solved,,in the cluster the three main back lights are 2.2w and the tell tails 1.2 MB keep them all.

It is easy to push out from the rear on a 129 you could run a flat bladed knife around the aperture first
 
OP
D

Drogo

Member
Joined
Jun 10, 2009
Messages
12
Reaction score
0
Location
Bexley
Your Mercedes
SL 500, Lexus IS200
  • Thread Starter
  • Thread starter
  • #12
Thanks Malcolm

I have a stock of 1.2's so a trip to Halfords is in order.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
364
Age
88
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Thanks Malcolm

I have a stock of 1.2's so a trip to Halfords is in order.

You may not get them from Halfords,, I believe the some Citroen use the same type, other that that it will be MB
 


Welwyn Merx Limited is a family run business with genuine passion, dedication and 25 years of experience dealing with Mercedes-Benz and AMG passenger cars.
Tel: 01707 395999www.welwynmerx.uk
Top Bottom