1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

R171-misfire

Discussion in 'Electrics, Vacuum, Ignition and ECU' started by elan, Jul 14, 2011.

Tags:
  1. elan

    elan New Member

    Messages:
    6
    Likes Received:
    0
    Joined:
    Jun 30, 2011
    Location:
    west yorkshire
    Your Mercedes:
    slk/2005/200
    Just bought a 2005 SLK200.Ist journey limped home on reduced power.Next morning car started up no probs,running sweetly,then started misfiring again,engine very lumpy and would not rev.Yellow engine warning light appeared but nothing in malfunction menu.Local garage diagnosed fault as coil on No.2 and changed it.Fault reappeared same day,this time they changed the injector on same pot,still fault did not disappear.
    When the fault is on, if the ignition is switched off, the car will restart ok and run till the fault reappears.It would appear something is rebooting when the ignition is switched off and back on again...could this be an ECU problem and has anyone had a similar fault.

    thanks...Bill
     
  2. Miffy

    Miffy Senior Member

    Messages:
    7,356
    Likes Received:
    2
    Joined:
    Sep 6, 2008
    Location:
    Bromley, London
    Your Mercedes:
    CLK 320 CAB Elegance C208
    If a dealer purchase, take it back and demand they fix it at their cost.

    Otherwise, stop replacing parts and get your fault codes read out.
     
  3. OP
    elan

    elan New Member

    Messages:
    6
    Likes Received:
    0
    Joined:
    Jun 30, 2011
    Location:
    west yorkshire
    Your Mercedes:
    slk/2005/200
    Hi Mark....bought privately,no cumback.diagnostic check showed nothing,this is why they had to start somewhere,so they started with the easy to change bits...thanks
     
  4. Miffy

    Miffy Senior Member

    Messages:
    7,356
    Likes Received:
    2
    Joined:
    Sep 6, 2008
    Location:
    Bromley, London
    Your Mercedes:
    CLK 320 CAB Elegance C208
    What diagnostic tool did they use? I would have thought any odbII reader would have shown the fault. It must be stored if you went into LIMP. See if you can find someone with STAR to carry out the diag
     
  5. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    318
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    Could this not be the MAF playing up, worth disconnecting and try the car
     

Share This Page