R230 SL no central locking

flowrider

Senior Member
Joined
Jul 21, 2014
Messages
3,650
Reaction score
1,612
Your Mercedes
SL500 (R230)
This lockdown is killing my SL! I have another issue today, the central locking has stopped working. The red LED flashes on the keys but the doors and boot don't unlock. I can access the car manually with the key and open the boot with the door switch, the locks all operate from the internal locking/unlocking buttons, the soft close boot works as does the seat lumbar support so I think the PSE pump is ok. I have checked all the fuses behind the drivers seat.

Any ideas where else to look?

Thanks
 
OP
flowrider

flowrider

Senior Member
Joined
Jul 21, 2014
Messages
3,650
Reaction score
1,612
Your Mercedes
SL500 (R230)
  • Thread Starter
  • Thread starter
  • #2
Plugged in the iCarsoft and there are no error codes for the PSE, so happy with that but the central locking still doesnt work. :(
 

LostKiwi

Senior Member
Joined
Aug 25, 2006
Messages
31,363
Reaction score
21,629
Location
Midlands / Charente-Maritime
Your Mercedes
'93 500SL-32, '01 W210 Estate E240 (RIP), 02 R230 SL500, 04 Smart Roadster Coupe, 11 R350CDi
This sounds like an issue with either the key or the radio antenna amplifier. Does it work if you point the IR at the receiver?
 
OP
flowrider

flowrider

Senior Member
Joined
Jul 21, 2014
Messages
3,650
Reaction score
1,612
Your Mercedes
SL500 (R230)
  • Thread Starter
  • Thread starter
  • #4
This sounds like an issue with either the key or the radio antenna amplifier. Does it work if you point the IR at the receiver?
Tried both keys and neither work. Batteries checked out ok in both keys. Pointing the key at the receiver in the door handle has never done anything and still doesn't.
 

LostKiwi

Senior Member
Joined
Aug 25, 2006
Messages
31,363
Reaction score
21,629
Location
Midlands / Charente-Maritime
Your Mercedes
'93 500SL-32, '01 W210 Estate E240 (RIP), 02 R230 SL500, 04 Smart Roadster Coupe, 11 R350CDi
In that case I'm going to guess at the radio receiver being toast.
 

Attachments

  • 230 antenna.pdf
    33.9 KB · Views: 22
OP
flowrider

flowrider

Senior Member
Joined
Jul 21, 2014
Messages
3,650
Reaction score
1,612
Your Mercedes
SL500 (R230)
  • Thread Starter
  • Thread starter
  • #6
In that case I'm going to guess at the radio receiver being toast.
An interesting document but it hasn't given me any inspiration. This will have to be the 3rd issue for my indy to fix (ac condenser, parking brake and now the central locking) I wonder what will come next.
 

LostKiwi

Senior Member
Joined
Aug 25, 2006
Messages
31,363
Reaction score
21,629
Location
Midlands / Charente-Maritime
Your Mercedes
'93 500SL-32, '01 W210 Estate E240 (RIP), 02 R230 SL500, 04 Smart Roadster Coupe, 11 R350CDi
An interesting document but it hasn't given me any inspiration. This will have to be the 3rd issue for my indy to fix (ac condenser, parking brake and now the central locking) I wonder what will come next.
From the document:
The RRCL signal is demodulated in the right antenna amplifier module
(A2/65), digitized and sent via a data output to the overhead control
panel (N70).

RRCL is the radio remote control if I understand correctly.
 
OP
flowrider

flowrider

Senior Member
Joined
Jul 21, 2014
Messages
3,650
Reaction score
1,612
Your Mercedes
SL500 (R230)
  • Thread Starter
  • Thread starter
  • #9
I have now scanned the 3 SAM's for error codes with my iCarsoft MBII, there are none. I have checked all 6 fuses associated with the central locking and they are all ok. On advice from an indy I removed a 20A fuse for 20 minutes to see if this kicked something into life but it didn't so looks like my only option now is STAR.
 

Avantgarde Automotive, Mercedes-Benz and SLR McLaren specialists. Service, repairs, diagnosis and motorsport preparation.
Unit 14 Hither Green Trading Estate, Clevedon, Somerset, BS21 6XU Tel: 01275 217270 Email:steve@avantgarde-automotive.co.uk
www.avantgarde-automotive.co.uk
Top Bottom