1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

R230 strange noise from rear boot area

Discussion in 'Suspension, Steering & Brakes' started by lovemerc, Oct 16, 2012.

  1. lovemerc

    lovemerc Senior Member

    Messages:
    226
    Likes Received:
    2
    Joined:
    Jan 31, 2010
    Location:
    South Wales
    Your Mercedes:
    ML250 GLE AMG Sport. Previously - SL500 R230 2003 & S430L W220 1999.
    Hi,

    In isolation from a suspect pump problem located in the boot, my SL has an odd noise that sounds like a knocking but is intermittent during a drive. It comes from the same area but is hard to pinpoint.
    It seems to happen more, when I reverse and stop quickly. But it also happens when coming to a stop or going slow, there just doesn't seem to be a clear pattern.

    Any advice would be appreciated so I can check...

    Thanks
    Mark.
     
  2. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    310
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    A loose baffle in the fuel tank is well known but only after Dec 02 I believe
     
  3. OP
    lovemerc

    lovemerc Senior Member

    Messages:
    226
    Likes Received:
    2
    Joined:
    Jan 31, 2010
    Location:
    South Wales
    Your Mercedes:
    ML250 GLE AMG Sport. Previously - SL500 R230 2003 & S430L W220 1999.
    Thanks Malcolm - can I access myself as a layperson?

    Also, thanks for your reply on the PSE, I assume this is not conntected so posted it here. Would you know if that 20A fuse is blowing, that it points to a replacement of the PSE or should I find the short causing the fusing?
     
  4. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    310
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    If the 20 amp fuse has blown, then the PSE pump is U/S
     
  5. scotty2hotty81

    scotty2hotty81 Senior Member

    Messages:
    132
    Likes Received:
    1
    Joined:
    Nov 1, 2006
    If it is the baffle in the tank it will get more apparent as the fuel level gets lower, major job to replace I'm afraid.
     
  6. OP
    lovemerc

    lovemerc Senior Member

    Messages:
    226
    Likes Received:
    2
    Joined:
    Jan 31, 2010
    Location:
    South Wales
    Your Mercedes:
    ML250 GLE AMG Sport. Previously - SL500 R230 2003 & S430L W220 1999.
    Thank you both, I appreciate the help.

    Malcolm, can you remind me, does the PSE operate with the Vario roof as I'm getting that message about the boot separator?

    Mark.
     
  7. Gkinghorn

    Gkinghorn Senior Member

    Messages:
    2,808
    Likes Received:
    178
    Joined:
    Jul 25, 2009
    Location:
    Bournemouth
    Your Mercedes:
    E350 CDI Cabriolet - 2011
    There are various 'home' remedies to it including the one where the guy used the broom handle to more or less smash it down... There is thread n here somewhere abut it all.. Will see if I can find it or someone else will...
     
  8. Gkinghorn

    Gkinghorn Senior Member

    Messages:
    2,808
    Likes Received:
    178
    Joined:
    Jul 25, 2009
    Location:
    Bournemouth
    Your Mercedes:
    E350 CDI Cabriolet - 2011
  9. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    310
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    Yes if the roof does not know where the boot id is it cannot work
     
  10. OP
    lovemerc

    lovemerc Senior Member

    Messages:
    226
    Likes Received:
    2
    Joined:
    Jan 31, 2010
    Location:
    South Wales
    Your Mercedes:
    ML250 GLE AMG Sport. Previously - SL500 R230 2003 & S430L W220 1999.
  11. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    310
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    If the pump is faulty I still have a nearly new one going
     
  12. Monday

    Monday Senior Member

    Messages:
    404
    Likes Received:
    59
    Joined:
    Apr 4, 2011
    Location:
    Surrey
    Your Mercedes:
    SL400 2016, E300 Coupe 2018
    Another source of R230 noises

    Just one other place to look. I had the boot lid LED stoplight replaced which involved stripping out the boot lid liner. Following this there was a random rattle from the rear of the car. The fact work had been done helped to pinpoint it but still took the dealer 5 hours to find (or so they said but they didn't charge me for it). I gather the work involved a "very small technician in the boot with a torch" and some "special MB foam padding".
     
  13. tode

    tode Senior Member

    Messages:
    1,952
    Likes Received:
    68
    Joined:
    Jun 12, 2011
    Location:
    NW FRANCE
    Your Mercedes:
    S350 btec 2011
    Just make sure it's not something silly like the tools moving it the spare wheel well . . . ;)
     
  14. drmw

    drmw Moderator

    Messages:
    3,683
    Likes Received:
    112
    Joined:
    Nov 25, 2007
    Location:
    Yorkshire
    Your Mercedes:
    M6 Cab - prior to that, SL63 AMG, A-M V8 Vantage, SL55, SL500 and many more
    or indeed the boot separator - sure someone posted on here that he eventually found that was the source of an annoying noise
     
  15. OP
    lovemerc

    lovemerc Senior Member

    Messages:
    226
    Likes Received:
    2
    Joined:
    Jan 31, 2010
    Location:
    South Wales
    Your Mercedes:
    ML250 GLE AMG Sport. Previously - SL500 R230 2003 & S430L W220 1999.
    All,
    Thank you so very much for these thoughts and replies, it's very much appreciated.
    Mark.
     
  16. maximan

    maximan New Member

    Messages:
    3
    Likes Received:
    0
    Joined:
    May 5, 2012
    Location:
    glos
    Your Mercedes:
    clk 230 KOMP, MGB GT `73, FZR 1000 Genesis, Honda C90.
    Sounds like it could be a broken rear coil spring.......but hey what do i know :D


    Maximan
     
  17. Gkinghorn

    Gkinghorn Senior Member

    Messages:
    2,808
    Likes Received:
    178
    Joined:
    Jul 25, 2009
    Location:
    Bournemouth
    Your Mercedes:
    E350 CDI Cabriolet - 2011
    Hopefully he got it fixed between October and now though :D
     
  18. maximan

    maximan New Member

    Messages:
    3
    Likes Received:
    0
    Joined:
    May 5, 2012
    Location:
    glos
    Your Mercedes:
    clk 230 KOMP, MGB GT `73, FZR 1000 Genesis, Honda C90.
    Yeah your right, was a little late but just scanning and i thought maybe i could help.

    Maximan
     

Share This Page