Revs up in neutral

shazsaf

Active Member
Joined
Nov 7, 2009
Messages
38
Reaction score
0
Can anybody help!! My clk 200k suddenly revs to 1500 revs when in neutral then when u put it in gear it goes back down to about 100. Anybody know wha the fault may be?
Ps it's a six speed manual

Regards
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
All I can think of is the throttle body air flow plate sticking,,wait to see what others think
 
OP
S

shazsaf

Active Member
Joined
Nov 7, 2009
Messages
38
Reaction score
0
  • Thread Starter
  • Thread starter
  • #3
Hi Malcolm will this show up in a diagnostic test?

Regards
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Owing to the safety of this fault I would put it on STAR and see
 
OP
S

shazsaf

Active Member
Joined
Nov 7, 2009
Messages
38
Reaction score
0
  • Thread Starter
  • Thread starter
  • #5
Do you thnk it's dangerous?
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
It can be very hard to drive an auto where the engine RPM can go up by so much.

Could you double check your figures,,the cars idle at around 700 rpm,, and you say that it goes up to 1500,,is that correct.
 
OP
S

shazsaf

Active Member
Joined
Nov 7, 2009
Messages
38
Reaction score
0
  • Thread Starter
  • Thread starter
  • #7
Hi Malcolm it's a manual gearbox, yes it's on 1.5 revs in neutral.

Thanks
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
I am now thinking that you may have motronic, and the reason fo the intermittent could well be the idle change over switch that is built into the throttle body.

If you look at the throttle body there is a plug on the side,,pull this out and see if it just stays at 1500 rpm ,if it is the same with the plug in or out,,then the switch inside will have worn and the car is staying running off the main ECU, and not the idle part.

The top of the air flow sensor can be taken off and the end stops filed away so that the switch can close
 
OP
S

shazsaf

Active Member
Joined
Nov 7, 2009
Messages
38
Reaction score
0
  • Thread Starter
  • Thread starter
  • #9
Hi just an update went to start it this morning when in idle it's does rev to 1500 then when u put your foot on brake the rev goes down to 1000 revs. Any help or info appreciated?

Malcolm is it still a throttle prob

thanks
 

turbopete

Senior Member
Joined
Feb 4, 2009
Messages
14,204
Reaction score
328
Age
46
Location
Spennymoor
Your Mercedes
2010 '60' Ford Mondeo 2.0TDCi Zetec (sorry)
some cars do keep the rpm high for a while (ie gearchanges) for a few seconds. this is normal and prevents unburnt fuel getting into the CATs
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
some cars do keep the rpm high for a while (ie gearchanges) for a few seconds. this is normal and prevents unburnt fuel getting into the CATs

They hold onto the gears Pete but this one is affected by the brake pedal, and this has to br that pipe with the one way valve in it.. max vacuum is at idle ,,take that pipe off or hole it and the idle RPM will shoot up
 


Text: V4B offer competitive leasing deals across the Mercedes Benz range, we have excellent knowledge and experience on the Mercedes product and we pride ourselves on providing excellent customer service.
V4B
Top Bottom