1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

s280 heater problems

Discussion in 'Electrics, Vacuum, Ignition and ECU' started by jonnybhoy67, Dec 9, 2012.

  1. jonnybhoy67

    jonnybhoy67 New Registration

    Messages:
    1
    Likes Received:
    0
    Joined:
    Dec 9, 2012
    Location:
    Glasgow
    Your Mercedes:
    s280 2000 2.8
    Hi i have a mercedes 280 automatic and when i put the heating on hot i only get cold air and i when i put it on front screen heater to clear the front windscreen it doesn't do it it only blows out cold air any idea what this could be?
     
  2. hmang

    hmang Senior Member

    Messages:
    856
    Likes Received:
    9
    Joined:
    Mar 9, 2007
    check out your duo valve ,they can stick or fail .
    although mine have usually failed to the hot position
    worth a look, bit awkward on yours, by wiper motor
    give em a tappy tap tap with big screw driver handle
     
    Last edited: Dec 11, 2012
  3. Steve@Avantgarde

    Steve@Avantgarde Forum Supporter Authorised Forum Supporter

    Messages:
    6,825
    Likes Received:
    1,003
    Joined:
    Dec 8, 2009
    Location:
    Bristol/Somerset
    Your Mercedes:
    C220CDI AMG Line Premium, SLR McLaren Roadster, SL55 & C32AMG
    I would check the engine thermostat first and foremost, make sure its opening and getting to 80 degrees on the temp gauge, if not then the coolant cant recirculate as far as the duo valves.
     

Share This Page