1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

s320 engine management no power

Discussion in 'Engine, Drivetrain, Fuel and Exhaust' started by ady74, Jan 6, 2013.

  1. ady74

    ady74 Senior Member

    Messages:
    130
    Likes Received:
    0
    Joined:
    Aug 14, 2012
    Location:
    manchester
    Your Mercedes:
    E270 E230 Vito
    My engine management light come on yesterday :( took it out today and it’s still on and very low power doesn’t like going up hills have to put your foot down to get up them and struggle to get 60mph on the motorway. There no strange noises and seems to be going through the gears ok.
    I was taking fuses out the day before checking for a battery drain could this be it or a coincidence?

    Any ideas appreciated before I take it to the garage?
     
    Last edited: Jan 6, 2013
  2. Miffy

    Miffy Senior Member

    Messages:
    7,356
    Likes Received:
    2
    Joined:
    Sep 6, 2008
    Location:
    Bromley, London
    Your Mercedes:
    CLK 320 CAB Elegance C208
    first stop is to get your codes read out on STAR (SDS)
     
  3. OP
    ady74

    ady74 Senior Member

    Messages:
    130
    Likes Received:
    0
    Joined:
    Aug 14, 2012
    Location:
    manchester
    Your Mercedes:
    E270 E230 Vito
    yes ill get it booked in for that tomorrow just wondered if any ideas before i face the shock of what its going to be! always just after xmas init:neutral:
     
  4. OP
    ady74

    ady74 Senior Member

    Messages:
    130
    Likes Received:
    0
    Joined:
    Aug 14, 2012
    Location:
    manchester
    Your Mercedes:
    E270 E230 Vito
    used it today and the lights gone off and powers back! Bonus!!!! :D
    just as i was about to book it in too. so dont know what it was but what ever it was it fixed!!
    my kind of problem one that fixes its self :lol:
     

Share This Page