1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SL 1991 m119 engine

Discussion in 'Engine, Drivetrain, Fuel and Exhaust' started by stoneage, May 14, 2019.

  1. stoneage

    stoneage Active Member

    Messages:
    25
    Likes Received:
    1
    Joined:
    Apr 18, 2010
    Location:
    east midlands leicester
    Your Mercedes:
    alfa, and merc 500sl
    Good eveing all, can some help with this problem? my 91/sl 500 has started get oil in the plug wells, ive change the rocker cover gaskets and the rubber gommet that sit in the rocker covers,but stiil the problem excits ,no oil in water not smoking no water lost ,on start up it miss for a few second then rums ok ,but when in traffic on tic over it mis fire, ive change all ignistion conponent? is this piston rings or head gasket, mileage is 150.000 thanks
     
  2. LostKiwi

    LostKiwi Senior Member

    Messages:
    17,038
    Likes Received:
    7,548
    Joined:
    Aug 25, 2006
    Location:
    Midlands / Charente-Maritime
    Your Mercedes:
    '93 500SL-32, '01 W210 Estate E240, 02 R230 SL500 (Malcolm Spec), 04 Smart Roadster Coupe
    Check you don't have a blocked engine breather.
     
  3. OP
    stoneage

    stoneage Active Member

    Messages:
    25
    Likes Received:
    1
    Joined:
    Apr 18, 2010
    Location:
    east midlands leicester
    Your Mercedes:
    alfa, and merc 500sl
    Thanks for you infor, clean all breathers, runs and starts better still has a miss fire on tick over, will now check all electrical ignistion parts , LostKiwi thanks
     
    LostKiwi likes this.
  4. Richard Moakes

    Richard Moakes Senior Member

    Messages:
    1,653
    Likes Received:
    120
    Joined:
    May 19, 2002
    Location:
    Newton Abbot, Devon, UK
    Your Mercedes:
    1991 R129.066 M119.960; 2005 W164.175 M113
    Increase spark plug gap to 1mm, it will smooth out the idle.


    Sent from my iPhone using Tapatalk
     

Share This Page