sl 55 electrical issues...

The Chap

Member
Joined
Sep 4, 2009
Messages
23
Reaction score
0
Location
London
Your Mercedes
2003 SL 55
H everyone - few issues have all come together on my 03 SL 55 and wonder if anyone can help?

- Passenger seat moves forward when pressing the button on the top to get into the back but does not go back into place when pressing the button to return it back? Although I can return the seat using the seat controls on the door...

- Boot does not auto close if it is partially or lightly closed, I remember it used to do this?

- O/S wing mirror reverses down when reversing but only returns back into place when the drivers mirror switch is accessed - don't think this is normal?

- I also occasionally have the old ABC warning light come up in white but no fluid leaks or any other related issues found?

Are these issues related to fuses? Otherwise does anyone know of any good independents near SW London?

Many thanks for any help!!!

EW
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
First welcome to the forum :D:D and we go through it all bit by bit

H everyone - few issues have all come together on my 03 SL 55 and wonder if anyone can help?

- Passenger seat moves forward when pressing the button on the top to get into the back but does not go back into place when pressing the button to return it back? Although I can return the seat using the seat controls on the door...
This is possibly a wire loose under the front edge of the seat,,could be a faulty switch, the whole switch part unclip and I can give you details of that
- Boot does not auto close if it is partially or lightly closed, I remember it used to do this?

The two rubber / plastic screws one each side may need just a quarter turn in to relieve the pressure, they are the stops under the boot bottom edge

- O/S wing mirror reverses down when reversing but only returns back into place when the drivers mirror switch is accessed - don't think this is normal?

This is normal and correct,,the switch must be in the down mode for the near side mirror to dip

- I also occasionally have the old ABC warning light come up in white but no fluid leaks or any other related issues found?

This will be a sensor failing, probably in one of the struts, if the car is plugged into STAR, it will say what one it is.
Just as a precaution, always park the car with the front wheels in the straight ahead position. I take it that once the warning has come up in white, the car will no longer raise on the button,,turning off and on again restores things to normal


Are these issues related to fuses? Otherwise does anyone know of any good independents near SW London?

Many thanks for any help!!!

EW

Nothing above is to do with any fuses
 
OP
T

The Chap

Member
Joined
Sep 4, 2009
Messages
23
Reaction score
0
Location
London
Your Mercedes
2003 SL 55
  • Thread Starter
  • Thread starter
  • #3
Many thanks Malcolm - these forums are great for sharing knowledge and experiences!

I found a slightly loose yellow plug under the seat and now the seat moves back - but only after I press the switch four or five times? Might that be the switch? If so, how do I unclip it?

Thanks for the advice about the screws - the boot now shuts cleanly enough although the motor still doesn't engage if I only partially close it. The boot mechanism works fine apart from that?

Roger having the wheels straight, do you know of a good, reputable indie in London with access to STAR?

Many Thanks!!

EW
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
It is more likely to be a faulty wire in the plug than the switch. the cover on the seat switch just prises out and there are 2 screws holding the switch and the belt carrier to the seat frame.

I could send you the details

I will see what else I have on the boot lock,,though we have another member with the same problem.

When parking up the car,,if the white ABC lamp has come on,just start the car again so that the warning is not there and it will not sink if the fault is a sensor in a strut.

I always drive the 100 miles to the experts on the south coast. Indies in London at a good price are hard to find
 
OP
T

The Chap

Member
Joined
Sep 4, 2009
Messages
23
Reaction score
0
Location
London
Your Mercedes
2003 SL 55
  • Thread Starter
  • Thread starter
  • #5
Thanks Malcolm!

Sorry for the delay reply - good news is that the electric passenger seat is now working fine so thank you for your help.

The boot lock issue would be most welcome as the lock itself works fine when I close the boot but just doesnt auto shut those last few inches as it used to.

Any recommendations for the sensor in the strut for the ABC warning? Or just leave it?

Also can you pass me the details of the experts on the south coast?

Thanks again for all your help!

EW
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
It is a hard thing regarding the strut sensor,, mine was livable with 18 months ago,,but coming on more now and a nuisance at that. As long as you never park up with the warning on the dash, the corner with the faulty strut will not sink




M.B.S
Mercedes Benz Specialist
Star Diagnostics / Servicing,Brakes,
ATA Accredited
Southampton
Phone 02380 407359
E.mail. Email@mbsofsouthampton.co.uk
Web site http://mbsofsouthampton.co.uk
 
Gtechniq manufactures an ultra durable and comprehensive range of surface protection products for cars, boats, RV's and aircrafthttp://www.gtechniq.com
Top Bottom