1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SL350 230 chassis roof issues

Discussion in 'Electrics, Vacuum, Ignition and ECU' started by AutoDynamics, Dec 2, 2012.

  1. AutoDynamics

    AutoDynamics New Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    Dec 2, 2012
    Location:
    Hertfordshire
    Your Mercedes:
    SL350
    Hi there people.
    Iv got a 2004 SL350 and the roof hydraulic pump seems to be low on oil/fluid. Can anyone tell me how you fill it up tho because it seems to be a sealed unit.
     
  2. SL55 Mark

    SL55 Mark Senior Member

    Messages:
    2,648
    Likes Received:
    354
    Joined:
    Oct 1, 2012
    Location:
    South
    Your Mercedes:
    2004 SL55 AMG
    What makes you think the fluid in the pump is low ? Are you having any symptoms ?

    If you are referring to the pump on the N/S of the boot under the foam, this provides the vacuum to the various systems in the car. Mine looks about half full of fluid, and it's working perfectly.
     
  3. OP
    AutoDynamics

    AutoDynamics New Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    Dec 2, 2012
    Location:
    Hertfordshire
    Your Mercedes:
    SL350
    The roof is not working. Diagnostic machine saying low on oil then checked the pump on top of the foam it's below the lowest arrow on the tank.
     
  4. SL55 Mark

    SL55 Mark Senior Member

    Messages:
    2,648
    Likes Received:
    354
    Joined:
    Oct 1, 2012
    Location:
    South
    Your Mercedes:
    2004 SL55 AMG
    Just a thought, have you checked for water under the pump, and also in the passenger footwell ?
     

Share This Page