1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SL350 lots of electrical problems at same time

Discussion in 'Electrics, Vacuum, Ignition and ECU' started by Devonian, Nov 27, 2012.

  1. Devonian

    Devonian Senior Member

    Messages:
    413
    Likes Received:
    3
    Joined:
    Jan 1, 2007
    My son's R230 (2003) has just started exibiting many electrical problems at the same time, symptoms include:
    central locking not working,
    dash displays shows error with roof - visit workshop,
    battery error - visit workshop
    only some of the instument cluster displays are working

    All these occurred at the same time, I'm hoping that maybe it's a low battery causing all the errors though after a 20 mile run they were still there.

    Has anyone had these symptoms before?
     
  2. SL55 Mark

    SL55 Mark Senior Member

    Messages:
    2,648
    Likes Received:
    354
    Joined:
    Oct 1, 2012
    Location:
    South
    Your Mercedes:
    2004 SL55 AMG
  3. Fleetwood

    Fleetwood Senior Member

    Messages:
    163
    Likes Received:
    0
    Joined:
    Jun 20, 2012
    Location:
    Horsham, West Sussex
    Your Mercedes:
    2005. SL350
    Yep sounds like water under the passenger carpet

    I had this with mine, I was lucky that I dried it out and all ok
     
  4. vauxhallmaniac

    vauxhallmaniac Senior Member

    Messages:
    558
    Likes Received:
    2
    Joined:
    Dec 2, 2007
    Your Mercedes:
    SL350/SLK320 Special Edt/SLK320 "Tinkerbelle Edition"
    Yep sounds like blocked drain N/S/F wheelarch, look in the blower motor air intake n/s of bonnet should be empty if its got water in it you have a blocked drain the water has flodded in through your blower motor and under the n/s carpet and is shorting the CAN electrics :(
     

Share This Page