SL350 R230 wont start, all the lights are on

Twoleftfeet

New Member
Joined
Dec 24, 2008
Messages
6
Reaction score
0
Your Mercedes
R230 SL350 2006
Drove the car a short distance, washed and polished it, took me about 3 hours, Dropped the roof down, turned on the key the dash lights up everything works except the engine won't turn over. Had a B service 300miles ago. Has it immobilized it's self? any suggestions would be most welcome. Thank you.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
So you turn the key, but the starter will not spin the engine

Is the locking working OK
 

carnut13

Senior Member
Joined
Jul 9, 2008
Messages
1,345
Reaction score
27
Location
Nr Sherborne, Dorset
Your Mercedes
R231 SL400 & Audi A1 Sport
Sorry but a silly question..is the gearlever in any gear other than " park" ?. Its been done before. Or maybe the car thinks it is. Make sure the gear selector is firmly in P
 
OP
T

Twoleftfeet

New Member
Joined
Dec 24, 2008
Messages
6
Reaction score
0
Your Mercedes
R230 SL350 2006
  • Thread Starter
  • Thread starter
  • #5
I have the car in park. I've locked the car and left it for 15 mins, Unlocked it and tried to start it again. No luck, Normally you turn the key and let go as it starts the engine and returns to its normal position. Every electrical item works with the ignition turned on apart from it will not spin the engine over. I've tried the spare key. Is there a switch under the brake pedal that could stop it from engaging the starter?. Is there a fuse that solely protects the starting?. Anymore suggestions?
 

Cole@MBS

Forum Supporter
Authorised Forum Supporter
Joined
Dec 1, 2008
Messages
13,633
Reaction score
772
Age
51
Location
Hedge End, Southampton
Website
www.mbssouthampton.co.uk
Your Mercedes
124 300 CE 24 Coupe, C220CDI, 1959:Morris Minor
Hold on, starter battery under the bonnet should kick in here, can you see on the dash what gear shes is showing, is she showing in park?
 
OP
T

Twoleftfeet

New Member
Joined
Dec 24, 2008
Messages
6
Reaction score
0
Your Mercedes
R230 SL350 2006
  • Thread Starter
  • Thread starter
  • #7
I unlock the car the mirrors fold out and everything is as normal, put the key in place, the dash lights up as bright as normal, it's showing "P" turn the key and nothing happens, and I mean nothing happens, no dimming of the dash lights to indicate a duff battery, no noise from anywhere, just silence. silence is good, but not when you want to go somewhere on a bank holiday. Is there a possibility of a crankshaft sensor doing this?. This is making me appreciate my old MGB a whole lot more. anymore suggestions would be very welcome. Thanks to those who have helped with ideas so far.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
I will have a search for you, and see what I can find
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
I have checked all that I can.

You have a starter fuse F52 in the rear fuse box

In your passenger side fuse box you have F29 30A
you have F30 30A and F49 15A

In the drivers side you have F1 30 amp


These are all of them that could affect the starting.

If all else fails, disconnect both batteries for 15 mins and try again
 

craighind

Member
Joined
May 25, 2009
Messages
11
Reaction score
0
Same problem

Spooky My SL320 Edition did exactly the same thing yesterday, all was well stoped then re started but the brake light warning lights were on, turned off then nothing all dash lights ok everthing else works but tun key and nothing, tried moving gear leaver to N after 5 mins started, only now it wont change up out of 1st gear, so drove all the way home at 30 mph, soon as got on drive turned off then from that point wont start again, I have disconected the battery and left it but still nothing, everthing else works, batterys fine it put the roof back up no problem ?? any ideas any one please
 
OP
T

Twoleftfeet

New Member
Joined
Dec 24, 2008
Messages
6
Reaction score
0
Your Mercedes
R230 SL350 2006
  • Thread Starter
  • Thread starter
  • #11
My problem seems to have righted itself. I took the advice of Malcolm(Television) and set about checking the fuses, starting in the rear.
I could only locate a 7.5 value fuse, so I decided to disconnect the rear battery and check the wires, all were perfect. Battery reconnect, the hazard lights start to flash, and won't cancel, I turn the key one notch and the hazards stop. turn the key further and she starts. Whats that all about!, everything seems fine now, I would dearly love to know what the problem was as I will always have it in my mind that it will be back to bite me again one day. Thanks Television another Luddite is back on the road
 

discoking

Active Senior Members
Joined
May 11, 2008
Messages
580
Reaction score
6
Location
South Shields
Website
www.facebook.com
Your Mercedes
1985 500SEL
Spooky My SL320 Edition did exactly the same thing yesterday, all was well stoped then re started but the brake light warning lights were on, turned off then nothing all dash lights ok everthing else works but tun key and nothing, tried moving gear leaver to N after 5 mins started, only now it wont change up out of 1st gear, so drove all the way home at 30 mph, soon as got on drive turned off then from that point wont start again, I have disconected the battery and left it but still nothing, everthing else works, batterys fine it put the roof back up no problem ?? any ideas any one please

I've had the same symptons on my '92 SL300 once or twice and my mam gets this on her '98 clk320 aswell.The way we get round it is to put the key in and if it doesn't start just hold the key in the start position and after 4 or 5 secs it comes to life.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
You are now in a position to pop into an indie and have the fault codes read out, there will be many,, let me know and I will try and work out what happened.

Anything that has digital micro components can lock up, and a power down can unlock things, Your fault is not something that I have ever heard of in a 230, and I think that you just drive off into the sunset and all lived happily ever after
 

Richard Moakes

Senior Member
Joined
May 19, 2002
Messages
1,751
Reaction score
204
Location
Newton Abbot, Devon, UK
Your Mercedes
1991 R129.066 M119.960; 2005 W164.175 M113
Lots of similar problems today.....

MBUK-License to use vehicle expired, please visit dealer for new license

Only kidding :D I do not envy you chaps with fully computerized cars :shock:
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Lots of similar problems today.....

MBUK-License to use vehicle expired, please visit dealer for new license

Only kidding :D I do not envy you chaps with fully computerized cars :shock:

Gor a 129 with all silly faults to deal with next Richard ,a late one though with lots of digital goodies:D
 

Richard Moakes

Senior Member
Joined
May 19, 2002
Messages
1,751
Reaction score
204
Location
Newton Abbot, Devon, UK
Your Mercedes
1991 R129.066 M119.960; 2005 W164.175 M113
Gor a 129 with all silly faults to deal with next Richard ,a late one though with lots of digital goodies:D

No chance Malcolm, I am a big fan of hydraulics, vacuum and conventional electronics. Electrical BUS technology is for computers not cars !

If it can't be diagnosed with a Tektronix analogue oscilloscope and a high impedance multimeter, then it's too complex for me :D
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
No chance Malcolm, I am a big fan of hydraulics, vacuum and conventional electronics. Electrical BUS technology is for computers not cars !

If it can't be diagnosed with a Tektronix analogue oscilloscope and a high impedance multimeter, then it's too complex for me :D

It has reached the point of stupidity, I will give you that ;) they are too complex to even have a decent wiring diagram any more
 


Save 30% on RAC Breakdown Cover
This year...next year... and every year you stay with RAC
Prices start from only £35.35*
This offer is available to all MERCEDES CLUB members and their immediate family**
Top Bottom