SL55 Fuse diagram

olimango

Member
Joined
Apr 22, 2009
Messages
17
Reaction score
0
Hi all

Does anyone know where I can get (or may be able to provide me with) a diagram of the fuses in my SL55. I bought it recently and the handbooks says it should be in the tool kit, but there isn't one there.

I've searched the net but can't seem to find anything.

The stereo has power, but no sound (after a couple of crackles it stopped playing any sound) and I've been told that it may be the fuse that's blown...but without a diagram I'm reluctant to remove anything.

Look forward to hearing from anyone who may be able to help.

Oli
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
What year is the car please
 
OP
O

olimango

Member
Joined
Apr 22, 2009
Messages
17
Reaction score
0
  • Thread Starter
  • Thread starter
  • #3
Hi Malcolm

The car is a Feb 2003, 52 plate SL55 AMG.

Many thanks
Oli
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
The comand fuse is F57 and F77 Bose is F66
 
OP
O

olimango

Member
Joined
Apr 22, 2009
Messages
17
Reaction score
0
  • Thread Starter
  • Thread starter
  • #5
Thanks Malcolm. Are these the ones which are situated in the compartment behind the drivers seat? Are fuse diagrams available or would I need to go to a main dealer to get hold of one?
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Yes they are behind the drivers seat


The Fuse paper is part number BR230 A 230 545 00 00
 
OP
O

olimango

Member
Joined
Apr 22, 2009
Messages
17
Reaction score
0
  • Thread Starter
  • Thread starter
  • #7
Hi Malcolm

I've been out and had a look, but the fuses aren't numbered and I don't have the diagram to show me which one is which number...anything you might have to help?

Do you have a diagram which you may be able to send me?

Thanks
Oli
 

mikestrivens

Senior Member
Joined
Nov 21, 2008
Messages
2,715
Reaction score
146
Location
Stockport
Your Mercedes
1995 W124 320TE, 1998 R129 SL500, 2016 Triumph Tiger 800 XCx
You could always just remove them one at a time to test them and put them straight back. That would at least tell you whether any are blown.
 
OP
O

olimango

Member
Joined
Apr 22, 2009
Messages
17
Reaction score
0
  • Thread Starter
  • Thread starter
  • #9
Hi all

I've taken each fuse out one by one, but they all seem to be ok.

When I press the FM/AM button on the COMAND it shows "Radio 1", however when I press the CD button it shows

CD Rom - CD Inserted (The Sat nav works)
CD Changer - No CD changer
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
This is not a fuse problem, does the phone work ? when it just show one station but no sound often a fault within the Comand, not finding the CD could be a fiber optic fault or due to the first fault just locked on radio 1
 
OP
O

olimango

Member
Joined
Apr 22, 2009
Messages
17
Reaction score
0
  • Thread Starter
  • Thread starter
  • #11
As I've only recently purcahsed the car I've not tried to connect the phone (assuming it bluetooth) but having looked it does show 'Tel Error' on the display.

The radio stations will change and when I put a CD in the slot (rather than the changer) it played, but without sound.

The Sat Nav also works, but again without any sound.

Thanks
Oli
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
You could pull the unit out and check the connections on the rear, though Bose was standard on the AMG cars it will not be that amp
 
OP
O

olimango

Member
Joined
Apr 22, 2009
Messages
17
Reaction score
0
  • Thread Starter
  • Thread starter
  • #13
I think I'll pop it along to the local dealer and see what they think. As I only bought it a few weeks ago in doing that I'll speak to the garage I bought it from and get them to sort out the cost of doing so...will keep you post.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
I think I'll pop it along to the local dealer and see what they think. As I only bought it a few weeks ago in doing that I'll speak to the garage I bought it from and get them to sort out the cost of doing so...will keep you post.

Good idea,, I have the same set up as you and on my car the sound went off, including the navigation, but the lingertronic still worked. I turned off a few times, hit it, swore, and jumped up and down, and it came back later,and been fine since
 
OP
O

olimango

Member
Joined
Apr 22, 2009
Messages
17
Reaction score
0
  • Thread Starter
  • Thread starter
  • #15
Right - the car is with MB and it isn't a fuse problem - the Comand is faulty. MB have said it's in the region of £2,800 - unless they can be repaired? Apparently MB don't repair them, but there are people on the planet who do....
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Yes there are people that fix them, yes it is disgusting that neither Bosch or MB have never set up any proper service on these things, you can buy them on Ebay but you have to know the number, and yours is the second series as of 07,02
 
OP
O

olimango

Member
Joined
Apr 22, 2009
Messages
17
Reaction score
0
  • Thread Starter
  • Thread starter
  • #17
I can't believe that MB don't repair them - it's really is a disgrace. I read on a similar forum about being careful not to purchase them from eBay because they can be 're-conditioned' ones which then fail. I live in the Midlands - anyone aware of anyone up this way who may repair them?
 

cavalree

New Member
Joined
Aug 24, 2014
Messages
2
Reaction score
0
Location
Wales
Your Mercedes
SL 55 AMG 2003
I have a similar request to that of olimango. My car is MB SL55 AMG born 3 Feb 2003.
Most of the gadjets work in my case apart from the CD changer. It worked perfectly yesterday until I restarted the car and then the screen informed me that the magazine was empty and continues to show this whatever I do. In my case also there is no Fuse diagram in the tool kit and there is NOTHING in the locker behind the drivers seat ! It is probably not a fuze problem now bu8t I would like to obtain a diagram for future use. Can anyone advise please.
 

cavalree

New Member
Joined
Aug 24, 2014
Messages
2
Reaction score
0
Location
Wales
Your Mercedes
SL 55 AMG 2003
PS -- I am able to play a CD by inserting it into the slot above the screen.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Too big to post up,, I can Email it to you.

Pull the fuse when you get the diagram, wait 10 mins, pop it back and give the cassette a few hard whacks and see.
 


Chris Knott Insurance, see oursticky posts here!
www.ckinsurance.co.uk
Top Bottom