SLK R170 Engine Management Light

owenrich

Senior Member
Joined
May 2, 2009
Messages
113
Reaction score
0
Your Mercedes
slk
Can anyone please tell me how you would know if engine oil had fouled the engine wiring harnes (loom)? The light is permantly on, but the car is running ok! Thank you in anticipation.
 
OP
O

owenrich

Senior Member
Joined
May 2, 2009
Messages
113
Reaction score
0
Your Mercedes
slk
  • Thread Starter
  • Thread starter
  • #3
Hi S-A-M, thank you for your reply. I have checked inside the CPU and it appears as good as new, very clean & dry. Could you tell me what diagnostic test code would show for oil in the loom? Initially a plug short in the second chamber was showing. I switched the plug with the another and no codes showed, even after a fast run round. However, several days, miles later the light is back on! Any more help would be greatly appreciated. Cheers. Owen.
 

Cole@MBS

Forum Supporter
Authorised Forum Supporter
Joined
Dec 1, 2008
Messages
13,633
Reaction score
772
Age
51
Location
Hedge End, Southampton
Website
www.mbssouthampton.co.uk
Your Mercedes
124 300 CE 24 Coupe, C220CDI, 1959:Morris Minor
Oil in the loom can throw fault codes around, One week it might show a 02 sensor fault, another week could show a airmass sensor fault , very hard to trace!

Did one last week, some photos on my web site!
 
OP
O

owenrich

Senior Member
Joined
May 2, 2009
Messages
113
Reaction score
0
Your Mercedes
slk
  • Thread Starter
  • Thread starter
  • #5
Hi Sam, thanks for your reply. All looks very clean under the bonnet and yet as you say the "readout" suggested a half dozen faults. I will try to check the 02 sensor as you suggested and will fit a "starter line" to the cam adjuster, as was suggested here by television & uncle ben. I checked your site and most impressed with the pictures. Thanks again for your and the other guys help. Cheers Owen.
 
Top Bottom