Top up Washer !

hog

Senior Member
Joined
Oct 14, 2009
Messages
154
Reaction score
4
Your Mercedes
ML320CDI+E350Bluetec Night Edition Estate
Hi I have replaced the low washer level switch in bottle on my S211 2007 car, but it still tells me to top up washer !!! Do I need to rest anything or do I have wiring problem?

Thanks for any help

Hog
 

mioba

Senior Member
Joined
Feb 19, 2006
Messages
7,975
Reaction score
4,724
Location
Nottingham and Köln
Your Mercedes
W124/E200, W220/S320CDI, W205/C200, W251/R350CDI 4Matic
Maybe thats all that needed doing ....
 

Botus

Senior Member
Joined
Jul 29, 2014
Messages
6,287
Reaction score
2,478
Location
UK
Your Mercedes
S500/2010/500
on many the seal for the pump weeps and the bottle empties itself. After 10 years and 100k the engine heat probably finishes it off

Its only a silly rubber grommet (that was probably never specc'ed to see 100C). They are available separately. But fitting might need the car stripped back to its basic body shell before you reach it. With Mercedes washer pumps often failing. Swapping it out makes life even harder for the grommet. (odd how most other the £7 pumps never die isn't it ?).
 
OP
H

hog

Senior Member
Joined
Oct 14, 2009
Messages
154
Reaction score
4
Your Mercedes
ML320CDI+E350Bluetec Night Edition Estate
  • Thread Starter
  • Thread starter
  • #6
Hi thanks topped up ;) no leaks at any of pump seals.

Hog
 

EmilysDad

Senior Member
Joined
May 8, 2012
Messages
12,215
Reaction score
5,798
Location
Bury Lancs
Your Mercedes
ML350
and the new switch definitely operates as the level goes high & low?
 

Botus

Senior Member
Joined
Jul 29, 2014
Messages
6,287
Reaction score
2,478
Location
UK
Your Mercedes
S500/2010/500
My omeba used to do this all the time.

With xenon's it had the 2 million gallon tank from hell hidden somewhere. When just topped up it was Ok, but one press of the washers when you had the lights on and it was game over for another 6 months.

When I rammed to the gunnels it would stay out for 5 minutes. I nearly mentioned that earlier, but just now thought what might do it. Pretty sure it didn't leak (but fairly sure my S500 does )…

But like the in car AC clogging up and giving legionella and other nasties, it seems the washer bottle is another deadly hiding place for monsters… With so many varieties of bubble bath mixing up the bubonic plague / next covid strain, I wonder if its a build up of slime on the level sensor that can be part of the dodgy readings?

If they fitted the sensor were the average tidal surge didn't misread all day long, it might end up with little decent flow of clean washer fluid and get a bit unresponsive?

grommet part 60, I think they are all the same GROMMET WASHER FLUID PUMP A 12 399 736 81 (drawing is a merc not yours)

347820d1485499656-windshield-washer-fluid-reservoir-leak-r230-washer.jpg
 
Last edited:

EmilysDad

Senior Member
Joined
May 8, 2012
Messages
12,215
Reaction score
5,798
Location
Bury Lancs
Your Mercedes
ML350
My omeba used to do this all the time.

With xenon's it had the 2 million gallon tank from hell hidden somewhere. When just topped up it was Ok, but one press of the washers when you had the lights on and it was game over for another 6 months.....

It was 'hidden' behind the front bumper ;) .... assuming you meant Omega B :rolleyes:
 

Botus

Senior Member
Joined
Jul 29, 2014
Messages
6,287
Reaction score
2,478
Location
UK
Your Mercedes
S500/2010/500
I had a moment topping it up once...…

I'd bought some of that Prestone autoexpess winning bubble bath... (didn't rate it by the way). Then got muddled what was what picked up a 5 litre bottle of the "yellow prestone stuff" lying about in what is the hideous mess of my garage. I got busy shoving it all in and was then going to top up with another 10 litres of water and let the bumps mix for me.

3.5 litres in and I was thinking you know this stuff is really syrupy for washer bottle thinners, smells a bit odd too.... as my mind meandered round the world wondering how come.... around the 4 litre mark I went …. oh bugger, that's because you just put 4 litres of diesel in the washer bottle you idiot !!!!

sure made the washer pump work for its living that day :eek:
 
Last edited:
Top Bottom