turbo problems hissing noise

chrisy5555

Senior Member
Joined
Dec 27, 2006
Messages
119
Reaction score
0
Hello

My turbo blew up this week

Mercedes said they had one which had been on a car then taken off sent away and tested and came back as perfect and they said I could have it for 500 quid

I took it to my local garage to be fitted it works but has a loud hissing noise when you put ya foot down
It also hesitates before going for it at around 3000 rpm

Any ideas what's wrong with my car and if the new turbo mercedes gave me for 500 quid will be covered and who will pay the refitting charges??
 

rf065

Senior Member
Joined
May 30, 2007
Messages
2,872
Reaction score
330
Location
Grossbritannien
Your Mercedes
SLC300 - C250d Estate 4 Matic & Z900rs
Interesting, when my turbo went, Mercedes fitted a new one under warranty which they said was noisy on the road test. They ordered another new one and changed it again.

Hissing noises usually come from a split hose though, I would check the hoses and connections first.

Russ
 
OP
C

chrisy5555

Senior Member
Joined
Dec 27, 2006
Messages
119
Reaction score
0
  • Thread Starter
  • Thread starter
  • #3
My car is over 3 now though unfortunatly
I thought hissing would be a hose I've had it in the past so replaced all hoses and garage checked them.
If I take it to Mercedes tomorrow do you think they could find it?
I'm starting to really hate the car now
 

rf065

Senior Member
Joined
May 30, 2007
Messages
2,872
Reaction score
330
Location
Grossbritannien
Your Mercedes
SLC300 - C250d Estate 4 Matic & Z900rs
I would take it to the dealer who sold you the turbo & see if they will check it free of charge as they have possibly sold you a duff turbo.

Who pays for what if it has to be taken off again is more of a problem. I would try to come to an amicable arrangement with them if they are willing to discuss it.

Russ
 
OP
C

chrisy5555

Senior Member
Joined
Dec 27, 2006
Messages
119
Reaction score
0
  • Thread Starter
  • Thread starter
  • #5
Well I have taken the car into mercedes today and left it there
So far they said they will charge me £100.00 to diagnose the problem
they said a metal rod they supplied with the turbo wasnt fitted, the garage said they did fit it and it wouldnt cause the hissing anyway.
They also said the speed sensor in the gearbox was broken so ill need one of them.
They did say if the turbo is broken then they will see about getting me a new one under warrenty but still cant fit it for me so i would have to go back to the garage who fitting it and pay another £160.00 even though mercedes gave me a used part which had been sent off, checked and said it was ok.
 

rf065

Senior Member
Joined
May 30, 2007
Messages
2,872
Reaction score
330
Location
Grossbritannien
Your Mercedes
SLC300 - C250d Estate 4 Matic & Z900rs
They did say if the turbo is broken then they will see about getting me a new one under warrenty but still cant fit it for me so i would have to go back to the garage who fitting it

I suspected they would say that, and cannot blame them for doing so.
I would have hoped they would have diagnosed whether the turbo was at faulty though for free. Even a goodwill agreement from Mercedes to pay part of the labour costs if you have to replace it again would have been a good result.

Russ
 
OP
C

chrisy5555

Senior Member
Joined
Dec 27, 2006
Messages
119
Reaction score
0
  • Thread Starter
  • Thread starter
  • #7
well latest update is its been at merc all day said the speed sensor was broken, but after clearing faults its ok now??
Origional turbo hiss noise was sorted and i was charged £109.00 so off i went only to find the noise was exactly the same, so i retured to mercedes where i was told they could have another look next week, i complained and they gave me my money back but did say it could only be a hose or intercooler.
I came home and found the bottom turbo hose was hanging off so connected this properly and the hiss has gone.

HOWEVER i am not still left with another annoying problem where when you floor it it revs to 3000rpm then stops then goes again mainly in the low gears, if you catch it where it revs straight past 3000 the problem isnt there but if its pulling from 2 to 3 then it stops then goes again

Does anyone have any idea whats causing this i feel like blowing the car up now!

thanks
 

5pares

Senior Member
Joined
Feb 25, 2005
Messages
224
Reaction score
0
Location
Suffolk
Your Mercedes
E320cdi
Has the linkage been fitted to the turbo?these have been causing problems.
 

Ian B Walker

Senior Member
Joined
Aug 21, 2006
Messages
401
Reaction score
0
Location
Lancashire
Your Mercedes
300td
Make sure the air inlet to the air filter is connected properly. Under load if not fitted correctly it will collapse and starve the engine and turbo of air. It happened to me some time ago and by pure chance I noticed it. This was also at 3000rpm. It is easy to overlook.
 


As a member of ourMercedes Owners' club, you will enjoy numerous savings on an expanding range of services including, Insurance, Parts and Servicing, RAC Membership plus much more.MBOmembers can save around £200.00 a year. You can join from as little as £30.00 and start to enjoy these savings immediately. You receive our monthly magazine and free classified ads when you decide to trade up a model.
Top Bottom